cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

290
Views
0
Helpful
3
Replies
khgrant
Cisco Employee

Adding an IOS-XR device to NSO 4.2.1

 

Hi All,

 

 

I’m having and issue connecting to a Cisco IOS-XR device using NSO.

 

 

I have added the below configuration to NSO:

 

 

admin@ncs# config

 

Entering configuration mode terminal

 

admin@ncs(config)# devices device lc13-asr9001-01

 

admin@ncs(config-device-lc13-asr9001-01)# sh f

 

devices device lc13-asr9001-01

 

address   10.50.141.197

 

port      22

 

authgroup physical

 

device-type cli ned-id cisco-ios-xr

 

device-type cli protocol ssh

 

state admin-state unlocked

 

config

 

  no ios:service password-encryption

 

  no ios:cable admission-control preempt priority-voice

 

  no ios:cable qos permission create

 

  no ios:cable qos permission update

 

  no ios:cable qos permission modems

 

  ios:ip source-route

 

  no ios:ip cef

 

  no ios:ip forward-protocol nd

 

  no ios:ipv6 cef

 

  no ios:dot11 syslog

 

!

 

!

 

admin@ncs(config-device-lc13-asr9001-01)#

 

commit

 

top

 

devices authgroups group physical

 

default-map remote-name <removed> remote-password <removed>

 

commit

 

 

 

 

Do I miss anything here? I can ssh/telnet to it from the CLI, but not from NSO CLI.

 

 

admin@ncs# devices device lc13-asr9001-01 connect           

 

result false

 

info Failed to connect to device lc13-asr9001-01: connection refused: Connection refused

 

admin@ncs#

 

 

ncsuser@ubuntu-server:~$ telnet 10.50.141.197

 

Trying 10.50.141.197...

 

Connected to 10.50.141.197.

 

Escape character is '^]'.

 

 

 

User Access Verification

 

 

Username: admin

 

Password:

 

 

 

RP/0/RSP0/CPU0:R7-lc13-asr9001-01#exit

 

Connection closed by foreign host.

 

 

ncsuser@ubuntu-server:~$ ssh admin@10.50.141.197

 

ssh: connect to host 10.50.141.197 port 22: Connection refused

 

ncsuser@ubuntu-server:~$

 

 

Thanks for your thoughts.

 

Kind regards,

 

 

Gerald

 

3 REPLIES 3
khgrant
Cisco Employee

 

Hi!

 

 

Please see below.

 

 

> On 14 nov. 2016, at 13:27, Gerald Debroux (gdebroux) <gdebroux@cisco.com> wrote:

 

>

 

> Hi All,

 

>

 

> I’m having and issue connecting to a Cisco IOS-XR device using NSO.

 

>

 

> I have added the below configuration to NSO:

 

>

 

> admin@ncs# config

 

> Entering configuration mode terminal

 

> admin@ncs(config)# devices device lc13-asr9001-01

 

> admin@ncs(config-device-lc13-asr9001-01)# sh f devices device

 

> lc13-asr9001-01

 

address   10.50.141.197

 

port      22

 

authgroup physical

 

device-type cli ned-id cisco-ios-xr

 

device-type cli protocol ssh

 

state admin-state unlocked

 

config

 

>   no ios:service password-encryption

 

>   no ios:cable admission-control preempt priority-voice

 

>   no ios:cable qos permission create

 

>   no ios:cable qos permission update

 

>   no ios:cable qos permission modems

 

>   ios:ip source-route

 

>   no ios:ip cef

 

>   no ios:ip forward-protocol nd

 

>   no ios:ipv6 cef

 

>   no ios:dot11 syslog

 

!

 

> !

 

> admin@ncs(config-device-lc13-asr9001-01)#

 

> commit

 

> top

 

> devices authgroups group physical

 

> default-map remote-name <removed> remote-password <removed> commit

 

>

 

>

 

>

 

> Do I miss anything here? I can ssh/telnet to it from the CLI, but not from NSO CLI.

 

It seems you cannot SSH from outside NSO either, see below.

 

>

 

> admin@ncs# devices device lc13-asr9001-01 connect           

 

> result false

 

> info Failed to connect to device lc13-asr9001-01: connection refused:

 

> Connection refused admin@ncs#

 

>

 

> ncsuser@ubuntu-server:~$ telnet 10.50.141.197 Trying 10.50.141.197...

 

> Connected to 10.50.141.197.

 

> Escape character is '^]'.

 

>

 

>

 

> User Access Verification

 

>

 

> Username: admin

 

> Password:

 

>

 

>

 

> RP/0/RSP0/CPU0:R7-lc13-asr9001-01#exit

 

> Connection closed by foreign host.

 

>

 

> ncsuser@ubuntu-server:~$ ssh admin@10.50.141.197

 

> ssh: connect to host 10.50.141.197 port 22: Connection refused

 

Does the host really have SSH enabled?

 

 

Fredrik

 

> ncsuser@ubuntu-server:~$

 

>

 

khgrant
Cisco Employee

 

Regarding connectivity, enable SSH on the device or change NSO to use telnet (device-type cli protocol telnet).

 

 

BR,

 

B.

 

khgrant
Cisco Employee

 

There was an SSH issue on the IOS-XR. All sorted now.

 

Thanks,

Gerald

 

Create
Recognize Your Peers
Content for Community-Ad