cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

144
Views
2
Helpful
3
Replies
Beginner

Device authgroup credentials

So far all my devices I’ve pulled into NSO have been configured with the default admin/admin credentials.   Now I have a couple of Nexus devices in my lab with credentials admin/test123.   I created a new authgroup called test with these credentials and added the nexus device using that authgroup but when I try to synch-from it looks like its still using the the default authgroup –

admin@ncs> show configuration devices authgroups group test

umap admin {

    remote-name     admin;

    remote-password $4$9rkCf8ROwVRwhYYI0d4IDw==;

}

[ok][2016-01-13 10:59:18]

admin@ncs> show configuration devices device nex-7702-a

address 10.255.138.95;

port      22;

ssh {

    host-key ssh-rsa {

        key-data "AAAAB3NzaC1yc2EAAAADAQABAAAAgQDSuX7/lBv9AobbXxAAggtTqsuhQnYXS075CIHWGGeU\nw3oGLZcetVSMQMczW7LbkECDSsXGBZNlqfcSfMWTtHUbaKO3aELgUCcN4sE5NWbS44IoDGJu\no4p8MKDajF9bw68Ch6baMEXkZyJVBWx1iSjX5ezv9gz2mXHePBezI2sypQ==";

    }

}

authgroup test;

device-type {

    cli {

        ned-id   cisco-nx;

        protocol ssh;

    }

}

state {

    admin-state unlocked;

}

[ok][2016-01-13 10:59:51]

admin@ncs# devices sync-from device [ nex-7702-a ]

sync-result {

    device nex-7702-a

    result false

    info Failed to authenticate towards device nex-7702-a: Bad password for local/remote user admin/admin Auth failed

}

Any help would be appreciated.

Thanks,

Bill

3 REPLIES 3

Re: Device authgroup credentials

Would it work with something like this?

group admin {

    default-map {

        remote-name     admin;

        remote-password $4$9rkCf8ROwVRwhYYI0d4IDw==;

    }

}

Cheers

Beginner

Re: Device authgroup credentials

I was able to get it to work with this –

group test {

umap admin {

remote-name admin;

remote-password $4$9rkCf8ROwVRwhYYI0d4IDw==;

}

}

Thanks,

Bill

Highlighted

Re: Device authgroup credentials

Great.

What was wrong?

Please share what you did to make it work and mark your post as answer, as it will serve as reference for others going through the same problem.

Thanks

Content for Community-Ad
FusionCharts will render here