cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
17
Views
0
Helpful
1
Replies
Highlighted
Cisco Employee

Error while configuring Juniper netsim device

Hi Team,

 

 

I am having below configuration in xml template to apply on netsim Juniper device and but while loading package in NCS I am getting error - “[edia_pe_inni_mx960_policy_bgp_ipv4.xml:13 missing tag: key2]”.

 

  <policy-options>

      <policy-statement>

        <name>a</name>

        <from>

          <prefix-list-filter>

            <list_name>IPV4-PFX</list_name>

            <orlonger/>

          </prefix-list-filter>

        </from>

      </policy-statement>

 

I appreciate any help.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Error while configuring Juniper netsim device

looks like you’re missing the “key2” tag…

 

This is what I got when i tried it directly on netsim…

 

 

 

j0(config)# configuration policy-options policy-statement AAA from prefix-list-filter IPV4_PFX orlonger j0(config-prefix-list-filter-IPV4_PFX/orlonger)# top j0(config)# commit
Commit complete.
j0(config)# exit
j0# show running-config configuration policy-options | display xml
<config xmlns="
http://tail-f.com/ns/config/1.0"> <configuration xmlns="http://xml.juniper.net/xnm/1.1/xnm"> <policy-options>
<policy-statement>
<name>AAA</name>
<from>
<prefix-list-filter>
<list_name>IPV4_PFX</list_name>
<key2>orlonger</key2>         </prefix-list-filter> </from>
</policy-statement>
</policy-options>
</configuration>
</config>
j0#

View solution in original post

1 REPLY 1
Cisco Employee

Re: Error while configuring Juniper netsim device

looks like you’re missing the “key2” tag…

 

This is what I got when i tried it directly on netsim…

 

 

 

j0(config)# configuration policy-options policy-statement AAA from prefix-list-filter IPV4_PFX orlonger j0(config-prefix-list-filter-IPV4_PFX/orlonger)# top j0(config)# commit
Commit complete.
j0(config)# exit
j0# show running-config configuration policy-options | display xml
<config xmlns="
http://tail-f.com/ns/config/1.0"> <configuration xmlns="http://xml.juniper.net/xnm/1.1/xnm"> <policy-options>
<policy-statement>
<name>AAA</name>
<from>
<prefix-list-filter>
<list_name>IPV4_PFX</list_name>
<key2>orlonger</key2>         </prefix-list-filter> </from>
</policy-statement>
</policy-options>
</configuration>
</config>
j0#

View solution in original post

Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.