cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
124
Views
0
Helpful
3
Replies
khgrant
Cisco Employee

Juniper ACX Error - While Applying Config

 

Hi Gurus,

 

While testing service against real Juniper ACX device. Customer is getting following error on NSO "3.4.2" using Juniper NED "3.0.21" . Please note that there is no error when same config is tested against netsim based devices. I am also attaching trace file to trace error.

 

Error in ncs-java-vm.log

com.tailf.maapi.MaapiException: ce-bglabc1100w.cpe.nj.panjde.comcast.net: Unexpected content: 'Setting up ACX specific options'

 

Last few lines from trace

 

<<<<in 3-Dec-2015::18:38:03.212 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X53/junos"

           xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

           message-id="4">

  <rpc-error>

    <error-severity>warning</error-severity>

    <error-path>[edit class-of-service interfaces]</error-path>

    <error-info>

      <bad-element>ge-1/2/1</bad-element>

    </error-info>

    <error-message>mgd: statement has no contents; ignored</error-message>

  </rpc-error>

  <ok/>

</rpc-reply>

<<<<in 3-Dec-2015::18:38:04.606 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X53/junos"

           xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

           message-id="5">

  <commit-results/>

  <ok/>

</rpc-reply>

 

>>>>out 3-Dec-2015::18:38:04.612 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

     message-id="6">

  <commit/>

</rpc>

>>>>out 3-Dec-2015::18:38:04.612 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

     message-id="7">

  <unlock>

    <target>

      <candidate/>

    </target>

  </unlock>

</rpc>

<<<<in 3-Dec-2015::18:38:27.654 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449 (badxml)

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X53/junos" xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="6">

Setting up ACX specific options

<ok/>

<<<<in 3-Dec-2015::18:38:27.656 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X53/junos"

           xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

           message-id="7">

  <ok/>

</rpc-reply>

>>>>out 3-Dec-2015::18:40:01.935 device=ce-bglabc1100w.cpe.nj.panjde.comcast.net session-id=17449 NCS close

/Imran Baig

1 ACCEPTED SOLUTION

Accepted Solutions
khgrant
Cisco Employee


It was a device issue as device was not sending correct response. Customer opened a ticket to get it resolved with BU.

/Imran Baig

View solution in original post

3 REPLIES 3
khgrant
Cisco Employee

 

Hi,

 

Have you checked the warning you are receiving?

 

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X53/junos"

           xmlns="urn:ietf:params:xml:ns:netconf:base:1.0"

           message-id="4">

  <rpc-error>

    <error-severity>warning</error-severity>

    <error-path>[edit class-of-service interfaces]</error-path>

    <error-info>

      <bad-element>ge-1/2/1</bad-element>

    </error-info>

    <error-message>mgd: statement has no contents; ignored</error-message>

  </rpc-error>

  <ok/>

</rpc-reply>

 

If that is not the problem, try to apply the commands directly in the device to check if juniper accepts them….basically, you need to find which command is creating this problem to find the problem in the NED

 

Roque

khgrant
Cisco Employee

 

Thanks Roque,

 

I will try both and will update this thread.

 

khgrant
Cisco Employee


It was a device issue as device was not sending correct response. Customer opened a ticket to get it resolved with BU.

/Imran Baig

View solution in original post

Content for Community-Ad

This widget could not be displayed.