cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
726
Views
2
Helpful
11
Replies
Cisco Employee

NSO WEB GUI for https

 

Hi All,

 

 

    Does Mac version of NSO support https Web UI?  On my Mac, it does not seem to be working, always got error "Secure Connection Failed The connection to localhost:8888 was interrupted while the page was loading.” And http (non-secure) Web works.

 

 

   The same thing for API on localhost with curl command, http works and https does not work, the error is: curl: (35) Server aborted the SSL handshake.

 

 

   And idea is appreciated. Thanks.

 

 

Regards

 

Mengbin

 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hi Hakan,

 

 

     Thanks for your comments here, a very good one. You are right, Mac has port 8888 occupied by something else on localhost. I have changed NSO listening port to 8889, then https on localhost with port 8889 works straight way.

 

 

   Thank you very much.

 

 

Regards

 

Mengbin

 

View solution in original post

11 REPLIES 11
Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

> Hi All,

 

>

 

>      Does Mac version of NSO support https Web UI?

 

 

Yes - identical to linux. Exactly.

 

 

/klacke

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hi Klacke,

 

 

   Thanks for your response. We have made it working, and still (do not know why), we have to use the IP address of the laptop not localhostŠ.

 

 

Regards

 

Mengbin

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Probably no localhost in the /etc/hosts file.

 

 

try ping localhost

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

There is ….

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hmm, if I recall correctly there are options to configure where NCS listens in the ncs.conf. Not sure if you have gone through that exercise. What does netstate says? Does NCS listen on all interfaces?

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

But it points to an ipv6 address (too) and that is preferred by your browser and NSO isn’t setup to listen to v6 addresses?

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hi Bostjan,

 

 

     Thanks a lot. Yes, I have done the configuration change in ncs.conf, and https works with indicating the real IP address of en0 of the mac https://<IP>:8888 works, but https://localhost:8888 failed.

 

 

Regards

 

Mengbin

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hi Hakan,

 

 

   Good point. And in my hosts file, IPv6 is commented out.

 

 

#

 

mgu$ more hosts

 

##

 

# Host Database

 

#

 

# localhost is used to configure the loopback interface

 

# when the system is booting. Do not change this entry.

 

##

 

  1. 127.0.0.1 localhost
  2. 255.255.255.255 broadcasthost
  3. 10.68.46.52     pc01
  4. 10.113.101.118 ucspm.ucspm2host.dublabucs.local

       

#::1 localhost

 



  

Regards

 

Mengbin

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Well if that didnt help then I have no idea.

 

 

As far as I know yaws (the web server) is setup to answer on all request and doesn’t care about domain names (no virtual server setup). At least for http, no idea about https.

 

 

like on my mac

 

 

10:59 $ cat /etc/hosts

 

127.0.0.1

 

localhost HNISKA-M-D399 no-care-for-a-name

 

 

 

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

My guess is that you have something else listening to 127.0.0. My first thought was that you could access the webui via 127.0.0.1 but not by using the name localhost, but now when I re-read it I see that you say you can access it via the network interface ip and not the localhost (nor 127.0.01 nor the name localhost).

 

 

You can for example stop NSO and run netstat -an | grep 8888, if anything comes up you have something else listening on that port.

 

Highlighted
Cisco Employee

Re: NSO WEB GUI for https

 

Hi Hakan,

 

 

     Thanks for your comments here, a very good one. You are right, Mac has port 8888 occupied by something else on localhost. I have changed NSO listening port to 8889, then https on localhost with port 8889 works straight way.

 

 

   Thank you very much.

 

 

Regards

 

Mengbin

 

View solution in original post