cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
123
Views
1
Helpful
9
Replies
Highlighted
Cisco Employee

NSO with Java 8

 

Hi folks,

 

Does NSO (latest version) support JDK 8 ?   The NSO pre-requisites indicate 1.6 or higher but we have to explicitly confirm Java 1.8 for my customer.

 

Thanks & Regards,
Nick Khemani

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: NSO with Java 8

 

Hi!

 

I use NSO with JDK/JRE 8, works perfect!

 

Br,

 

Fredrik

 

View solution in original post

9 REPLIES 9
Cisco Employee

Re: NSO with Java 8

 

Hi!

 

I use NSO with JDK/JRE 8, works perfect!

 

Br,

 

Fredrik

 

View solution in original post

Cisco Employee

Re: NSO with Java 8

 

Thanks Fredrik – that is good to know. Is Java JDK 8 also officially supported by Tail-f BU ?

 

 

Thanks & Regards,

 
Nick Khemani

Cisco Employee

Re: NSO with Java 8

 

Hi!

 

We're running regression tests on Java 8 with both Oracle's JDK and OpenJDK.

 

Br,

 

Fredrik

 

Cisco Employee

Re: NSO with Java 8

 

I see. And what versions of NSO are you using during regression testing phase ? Are NSO 4.0.x involved ? I need to provide a clear answer to customer if Java 8 will be supported or not.

 

 

Thanks & Regards,

 
Nick Khemani

Cisco Employee

Re: NSO with Java 8

 

Hi Nick,

 

I am the originator for the information that the regression test run both oracle and openjdk. I checked it and it actually only runs on openjdk.

 

It is however run for jdk7 and jdk8 and for both NSO 4.0.x and coming later versions like NSO 4.1

 

 

The code is compiled with “1.6” (source and target) compatibility and the released jars can therefore be used for customers running java 6 or later.

 

There is no fancy stuff in the api:s that uses additions in java (since 1.6).

 

 

Regards

 

/Try

 

Cisco Employee

Re: NSO with Java 8

 

We need to have a simpler answer to this question. Since the documentation says 1.6 or higher, and 1.8 is higher, then it is supported. Is it not that simple?

 

Cheers,

 

KJ.

 

Cisco Employee

Re: NSO with Java 8

 

Works for me. Thanks KJ.

 

Thanks & Regards,

 
Nick Khemani

Cisco Employee

Re: NSO with Java 8

 

Let me verify with NSO engineering, or otherwise we would need to update the documentation.

 

Cheers,

 

KJ.

 

Cisco Employee

Re: NSO with Java 8

 

Hi KJ,

 

It is that simple!

 

I was just explaining how we procure the correctness of that sentence in the documentation.

 

 

Cheers

 

/Try

 

Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.