cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
60
Views
0
Helpful
3
Replies
Highlighted
Cisco Employee

Package Load Error

 

Hi Guys,

 

 

I am trying to load some packages to nso and get errors while loading. While loading the packages one by one I get the below error for ios ned:

 

[cisco@localhost ncs-run]$ ncs --with-package-reload

 

Failed to load file ./state/packages-in-use/1/cisco-ios/load-dir/._tailf-ned-cisco-ios-meta.fxs: ./state/packages-in-use/1/cisco-ios/load-dir/._tailf-ned-cisco-ios-meta.fxs: Must be recompiled! (<<0,5,22,7>>)

 

Daemon died status=21

 

 

 

Steps followed:

 

  • Received 4 packages used on another setup ( 2 neds and 2 custom)
  • Tried loading them to an nso 4.2 instance on linux and faced loading issues
  • Next, downloaded nso 4.1.1 (version used on another server where these packages work) for my mac
  • Package reload was successful on mac
  • Then setup nso 4.1.1 on separate linux vm
  • Tried package reload and faced the above error
  • Set source correctly and compiled package without error
  • However package reload failed again with the same error
  • Uninstalled and reinstalled nso but still no luck

  

 

I would appreciate if someone can give me some pointers on how to fix this or debug this better.

 

 

Regards

 

Himanshu

 

3 REPLIES 3
Highlighted
Cisco Employee

 

Hi Himanshu,

 

 

You need a version of the Cisco IOS NED which matches the version of NSO you are running. Perhaps you can provide more information regarding the cisco IOS NED package you are attempting to load.

 

 

-Dan

 

Highlighted
Cisco Employee

 

<ncs-package xmlns="http://tail-f.com/ns/ncs-packages">

 

  <name>cisco-ios</name>

 

  <package-version>4.0.4</package-version>

 

  <description>NED package for Cisco IOS</description>

 

  <ncs-min-version>3.4.2</ncs-min-version>

 

  <ncs-min-version>4.0</ncs-min-version>

 

  <ncs-min-version>4.1</ncs-min-version>

 

 

-H

 

Highlighted
Cisco Employee

 

Hi Himanshu,

 

 

Okay, well I would just use a version of the NED which matches the version of NSO you wish to run. So don’t bother recompiling only use the pre-built version of the NED. Although you say it was built correctly something doesn’t quite match between the NED version it was built with and the NSO version.

 

 

-Dan

 

Content for Community-Ad
Cisco Community August2020 Spotlight Award Winners
This widget could not be displayed.