cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
296
Views
2
Helpful
1
Replies
ian.scheidler1
Enthusiast

result false info internal error

Hi,

I have a JunOS device which I cannot connect to. I had just added it and succesfully fetched the host keys for SSH, then ran into a few problems connecting from NSO via SSH ("...Subsystem not supported..." and Authentication problems). I played around with the SSH settings on the JunOS (set SSH v1 and activated root-authentication and created appropriate user mapping in NSO). I had then connected successfully once to the device and went for lunch. When I got back and tried to connect again I got the error

Unfortunately the error message doesnt give much information on what happens:

From the ncs_cli I try to connect and get this:

admin@ncs# devices device JunOS connect

result false

info internal error

admin@ncs#

From the WebUI I get pretty much the same. See attached screenshot.

I am using the following NED for Juniper: juniper-junos version: 3.0.27

I tried to have a look in the logs, but there isnt really much more info to be found there either (I checked ncs.log to no avail but found sth. in devel.log, where I can see my attempts to connect, but not much more info on what is causing the error). Here is a short excerpt from the log (I think it is from one of the connect attempt via the webUI):

<INFO> 11-Oct-2016::15:20:19.828 osboxes ncs[2122]: ncs failed to connect to JunOS: noconnection

<DEBUG> 11-Oct-2016::15:20:19.830 osboxes ncs[2122]: devel webui_appmod_jsonrpc

REQUEST sessST6hiwA2gZo447egesudbA==: {"jsonrpc":"2.0","id":69,"method":"run_action","params":{"th":1,"path":"/ncs:devices/device{\"JunOS\"}/connect"}}

RESPONSE sessST6hiwA2gZo447egesudbA==: {"jsonrpc":"2.0","result":[{"name":"result","value":"false"},{"name":"info","value":"internal error"}],"id":69}

Any idea what could cause this error and how to go about resolving it?

P.S.: I tried restarting ncs completely which didn't help.

1 ACCEPTED SOLUTION

Accepted Solutions
ian.scheidler1
Enthusiast

OK...I set the SSH version back to v2 (default) on the JunOS. The I kept getting "info Failed to authenticate towards device JunOS: SSH subsystem not supported".

I needed to activate the SSH Subsystem by entering the following commands in JunOS cli:

configure

edit system services

set netconf ssh

set ssh

Now I managed to connect again. Still not sure what happened during my lunch break as I believe I had connected succesfully once. anyway, now it seems to work.

View solution in original post

1 REPLY 1
ian.scheidler1
Enthusiast

OK...I set the SSH version back to v2 (default) on the JunOS. The I kept getting "info Failed to authenticate towards device JunOS: SSH subsystem not supported".

I needed to activate the SSH Subsystem by entering the following commands in JunOS cli:

configure

edit system services

set netconf ssh

set ssh

Now I managed to connect again. Still not sure what happened during my lunch break as I believe I had connected succesfully once. anyway, now it seems to work.

View solution in original post

Content for Community-Ad

This widget could not be displayed.