cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
63
Views
2
Helpful
3
Replies
Cisco Employee

StarOS NED Error when we try to sync from ASR device

We are noticing String Out of Bounds error when we try to sync from ASR device. Following is the error. We are using NCS 3.3.3 and StartOS NED version ncs-3.3-cisco-staros-3.0.0.13_17064c8.tar.gz

Sync error:
Device NDC2C1
Result false
Info Network Element Driver error ned_show_cli for device NDC2C1: String index out of range: -3

Following is Java Log.

<ERROR> 23-Jun-2015::10:58:45.642 NedWorker Ned-Worker-Thread-0: - NedWorker error for ned_get_trans_id
java.lang.StringIndexOutOfBoundsException: String index out of range: -3
at java.lang.String.substring(String.java:
1911)
at com.tailf.packages.ned.ciscoStaros.CiscoStarosNedCli.strip(CiscoStarosNedCli.java:
1228)
at com.tailf.packages.ned.ciscoStaros.CiscoStarosNedCli.getConfig(CiscoStarosNedCli.java:892)
at com.tailf.packages.ned.ciscoStaros.CiscoStarosNedCli.getTransId(CiscoStarosNedCli.java:740)
at com.tailf.ned.NedWorker.dorun(NedWorker.java:
1575)
at com.tailf.ned.NedWorker.run(NedWorker.java:255)

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: StarOS NED Error when we try to sync from ASR device

Please find enclosed the printout of the log “ned-cisco-staros-NDC2CSVC1GW01.trace”; while trying to sync. The StarOS version is 17.3.0.

Please let us know if you need further information.

View solution in original post

3 REPLIES 3
Highlighted
Cisco Employee

Re: StarOS NED Error when we try to sync from ASR device

The NED first reads in the staros version.  What version is your ASR device running?

Also turn on trace for the device and let’s look at the device trace log – in the same directory as your java.log file.

To turn on trace:

A trace log can be created to see what is going on between NCS and the device CLI enable trace. Use the

following command to enable trace:

admin@ncs(config)# devices global-settings trace raw trace-dir logs

admin@ncs(config)# commit

Commit complete.

Highlighted
Cisco Employee

Re: StarOS NED Error when we try to sync from ASR device

Please find enclosed the printout of the log “ned-cisco-staros-NDC2CSVC1GW01.trace”; while trying to sync. The StarOS version is 17.3.0.

Please let us know if you need further information.

View solution in original post

Highlighted
Cisco Employee

Re: StarOS NED Error when we try to sync from ASR device

I would get Fred’s take on this.

That  is the same version of staros that  I run – but I run the 3.4.1 NED – but that command appears to be supported:

[local]qvpc-di# show config

active-charging     apn       card      checksum  context   errors    obsolete-encryption           port

showsecrets         srp       url       verbose   |         <cr>

[local]qvpc-di# show version

Active Software

  Image Version:                  17.3.0.60288

  Image Build Number:             60288

  Image Description:              NonDeployment_Build

  Image Date:                     Fri Jun  5 06:01:12 EDT 2015

  Boot Image:                     /flash/production.60288.qvpc-di.bin

[local]qvpc-di#

[local]NDC2CSVC1GW01#

  *** output 23-Jun-2015::13:36:46.759 ***

-- Inspecting version string --

-- Found Cisco device --

<< 23-Jun-2015::13:36:46.759 CONNECTED 0

>> 23-Jun-2015::13:36:46.766 SHOW 0: <all>

show config obsolete-encryption

  *** input 23-Jun-2015::13:36:46.771 ***

show config obsolete-encryption

Unknown command - "obsolete-encryption", unrecognized keyword

[local]NDC2CSVC1GW01# << 23-Jun-2015::13:36:46.773 SET-TIMOUT

<< 23-Jun-2015::13:36:46.774 ERROR: Network Element Driver error ned_show_cli for device NDC2CSVC1GW01: String index out of range: -3

>> 23-Jun-2015::13:36:46.774 CLOSE 0: (Pool: false)

<< 23-Jun-2015::13:36:46.775 CLOSED

This widget could not be displayed.