cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
482
Views
0
Helpful
3
Replies
Beginner

AXL User Add/Update fails on directoryURI field

I'm working on scripts to add and update user's directoryURI setting for a CallManager 9.1.2 server.  But I am getting AXL errors saying the hostname can contain only alphanumeric characters.  Problem is the hostname should be the domain name with periods.  Works via native CUCM Admin pages, but not via AXL.  AXL read out is below...

REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://www.cisco.com/AXL/API/9.0"><SOAP-ENV:Body><ns1:updateUser><userid>Test1</userid><directoryUri>Test1@mydomain.com</directoryUri></ns1:updateUser></SOAP-ENV:Body></SOAP-ENV:Envelope> 

RESPONSE: <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><soapenv:Fault><faultcode>soapenv:Server</faultcode><faultstring>Invalid format for directoryUri. Valid format is username@hostname. Hostname can only contain alphanumeric characters.</faultstring><detail><axlError><axlcode>5003</axlcode><axlmessage>Invalid format for directoryUri. Valid format is username@hostname. Hostname can only contain alphanumeric characters.</axlmessage><request>updateUser</request></axlError></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

Tried encoding the period in HTML format.  Works with Test1@mydomain, but always fails when adding .com to the end.  Any ideas?  Similar results on later 9.X or 10.X code?

Everyone's tags (5)
3 REPLIES 3
Contributor

Re: AXL User Add/Update fails on directoryURI field

Got the same problem in my testing as well.

Looks like a bug to me, since the schema indicated this is a string type.

Will check with AXL team to get confirmation

Regards,

Howard

Highlighted
Beginner

Re: AXL User Add/Update fails on directoryURI field

Verified this does work on version 10.5.1.10000-7.  Not sure if fixed on recent patch for 9.1.2 yet.

Contributor

Re: AXL User Add/Update fails on directoryURI field

Confirmed by AXL team. The issue is applicable only for 9.x and 8.x branches and not been integrated to the releases yet.

The Bug ID is: CSCuo67622

Regards,

Howard

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards