cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1190
Views
0
Helpful
3
Replies

CF_GENERIC_SYSTEM_RESOURCE_AVAILABILITY while recording

Abhiram Kramadhati
Cisco Employee
Cisco Employee

Hi guys,

I am using selective recording with Mediasense and UCCX Finesse. In the browser console logs, I get this error: CF_GENERIC_SYSTEM_RESOURCE_AVAILABILITY

This is coming from the JTAPI logs and I can see this there:

I have UCCX 11 and MS 11. I have done all the configurations, but I am getting an error when the API call to start recording is made. I tracked it down to the JTAPI logs:

4458: May 22 23:42:55.508 PDT %JTAPI-PROTOCOL-7-UNK:(P2-10.10.10.40) [MIVR_SS_RM_TPCCPROCESSOR-298-16-StartRecordingReqMsgHandler] sending: com.cisco.cti.protocol.CallRecordingStartRequest {

  sequenceNumber       = 123

  lineCallManagerID    = 1

  lineID               = 178

  callLegCallManagerID = 1

  callLegID            = 32114742

  tone                 = 3

  invocationType       = 1

  }

4459: May 22 23:42:55.511 PDT %JTAPI-PROTOCOL-7-UNK:(P2-10.10.10.40) received Response: com.cisco.cti.protocol.CallRecordingStartResponse {

  sequenceNumber = 123

  result         = -1932787536

  }

4460: May 22 23:42:55.512 PDT %JTAPI-JTAPI-7-UNK:[[agent1ipc/[2003::1/(P2-uccxrmcm) GCID=(1,5065)->ACTIVE]->ESTABLISHED]->TALKING]ResourceUnavailableExceptionImpl caught: Unable to record the call.

However, the SIP trunk is in full service and I have done all the configuration as per the guide. Is there anything that I am missing?

Cheers,

Abhiram Kramadhati

3 Replies 3

dekwan
Cisco Employee
Cisco Employee

Hi Abhiram,

I moved your forum post to the MediaSense forum because although you are using a Finesse API, it is really a MediaSense functionality and the errors will be better suited in this forum.

I will let those more familiar with the MediaSense features to answer your question.

Thanx,

Denise

You might want to try..

You have to configure UCM to support on demand recording with MediaSense.

There is also a thread here that could be of some help...

All good with this, thanks. Was to do with the BIB. It was set to DEFAULT and I assumed that meant on. Doh!