cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
319
Views
0
Helpful
4
Replies
Highlighted
Rising star

updateRemoteDestination - axlError -1 when assigning a ownerUserId that has enablemobility = false on CUCM11.5

Hi

Found another one on CUCM 11.5. I was going throgh my remote destination tests, and one of them tried to change the ownerUserId to a user that doesn't have mobility enabled.

The AXL I'm sending looks like this

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://www.cisco.com/AXL/API/11.5"><soapenv:Header/><soapenv:Body><ns:updateRemoteDestination sequence="1"> <destination>00767777777</destination><newName>rd_test_updated</newName><newDestination>00767777778</newDestination><answerTooSoonTimer>5000</answerTooSoonTimer><answerTooLateTimer>25000</answerTooLateTimer><delayBeforeRingingCell>10</delayBeforeRingingCell><isMobilePhone>false</isMobilePhone><enableMobileConnect>true</enableMobileConnect><remoteDestinationProfileName uuid="{0E7336F5-05FE-F52A-21C9-0D40A8445F42}">RDP_testing</remoteDestinationProfileName><lineAssociations><lineAssociation><uuid>{D27C7699-D7C6-9C0E-066B-C729898568B8}</uuid><index>1</index></lineAssociation></lineAssociations><timeZone>Etc/GMT</timeZone><ownerUserId>lsste</ownerUserId><singleNumberReachVoicemail>Use System Default</singleNumberReachVoicemail><dialViaOfficeReverseVoicemail>Use System Default</dialViaOfficeReverseVoicemail></ns:updateRemoteDestination></soapenv:Body></soapenv:Envelope>

Then we have the backend doing some DB checks before formulating the update command

2016-07-21 21:21:53,917 DEBUG [http-bio-443-exec-1] servletRouters.AXLAlpha - Request processed by AXIS

2016-07-21 21:21:53,923 DEBUG [http-bio-443-exec-1] axlapiservice.Handler - dbConnector Initialization in handler.java

2016-07-21 21:21:53,923 DEBUG [http-bio-443-exec-1] axlapiservice.Axl - Connection given to current thread

2016-07-21 21:21:53,945 DEBUG [http-bio-443-exec-1] axlapiservice.AXLCallFlow - In begin transaction of AXLCallflow and created pub connector

2016-07-21 21:21:53,945 DEBUG [http-bio-443-exec-1] axlapiservice.Handler - ClassCast Exception Did not Occurs

2016-07-21 21:21:53,945 DEBUG [http-bio-443-exec-1] axlapiservice.Handler - flag is not equal to update

2016-07-21 21:21:53,946 DEBUG [http-bio-443-exec-1] axlapiservice.Handler - select pkid from RemoteDestinationDynamic where Destination='00767777777'

2016-07-21 21:21:53,948 DEBUG [http-bio-443-exec-1] axlapiservice.UpdateRemoteDestinationHandler - 00767777777

2016-07-21 21:21:53,948 DEBUG [http-bio-443-exec-1] axlapiservice.UpdateRemoteDestinationHandler - select t1.moniker from typemodel t1, device t2, remotedestination t3, remotedestinationdynamic t4 where t1.enum=t2.tkmodel and t2.pkid=t3.fkdevice_ctird and t3.pkid= t4.fkremotedestination and t4.destination='00767777777'

2016-07-21 21:21:53,949 DEBUG [http-bio-443-exec-1] axlapiservice.UpdateRemoteDestinationHandler - Select pkid,enablemobility from enduser where userid='lsste'

2016-07-21 21:21:53,952 ERROR [http-bio-443-exec-1] axlapiservice.AXLAPIServiceSkeleton - com.cisco.www.axlapiservice.AXLAPIServiceSkeleton@17f4260

java.lang.NullPointerException

When I ran this last query manually, I saw that enablemobility was false. So... it makes sense that the operation fails. However, I'd argue that the error returned should be something more useful that what is actually being returned:

2016-07-21 21:21:53,963 DEBUG [http-bio-443-exec-1] servletRouters.AXLAlpha - <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><soapenv:Fault><faultcode>soapenv:Server</faultcode><faultstring></faultstring><detail><axlError><axlcode>-1</axlcode><axlmessage></axlmessage><request>updateRemoteDestination</request></axlError></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

4 REPLIES 4
Highlighted
Cisco Employee

Thanks Stephan...do you know if this returned a different (more helpful) error in previous versions?  We can open a defect either way, but would be good to keep the previous error for consistency, if it makes sense...

Highlighted

Issue CSCva58593 opened for tracking

Highlighted

Good question. I think it was different on UC 10.5 - I seem to recall getting warnings about users not being enabled for mobility. I can't switch back the cluster at this point though to run the unit tests again. But a message about users not being mobility enabled is something I've definitely seen at some point in the past (it could also have been UC 8.5 or 9 though).

Highlighted

FYI, the issue CSCva58593 has been resolved in code, tentatively to be included in the 12.0 release.  If you are a customer need the fix for this via a CUCM 'engineering special' (limited testing 'patch' release) please open a DevNet ticket or TAC case, respectively, and we can request it be included in the next ES release.

This widget could not be displayed.