10-17-2013 08:13 AM
Dears
I have few questions regarding EVC and its assiciation with VPLS and would like your assistance please regarding them
1- Is there any difference between below options
Option 1a
************
interface GigabitEthernet3/0/0
service instance 100 ethernet
encapsulation dot1q 100
bridge-domain 100
Option 1b
************
interface GigabitEthernet3/0/0
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100
|||
2- Is there a need need to define evc globally
Option 2a
************
ethernet evc evc-test
interface GigabitEthernet3/0/0
service instance 2001 ethernet evc-test
encapsulation dot1q 2001
rewrite ingress tag pop 1 symmetric
bridge-domain 2001
interface vlan 2001
xconnect vfi vfi-test
l2 vfi vfi-test manual evc-test
vpn id 2001
neighbor 1.1.1.1 encapsulation mpls
Option 2b
************
interface GigabitEthernet3/0/0
service instance 2001 ethernet
encapsulation dot1q 2001
rewrite ingress tag pop 1 symmetric
bridge-domain 2001
interface vlan 2001
xconnect vfi vfi-test
l2 vfi vfi-test manual
vpn id 2001
neighbor 1.1.1.1 encapsulation mpls
|||
3- What does "bridge-domain vlan" configured under "l2 vfi" do ?
R6(config-if-srv)#l2 vfi vfi-test manual evc-test
R6(config-vfi)#?
VFI configuration commands:
bridge-domain Bridge Domain
cfm Ethernet CFM EFP subcommands
default Set a command to its defaults
exit Exit from vfi configuration mode
forward Specify forwarding of types of traffic
neighbor VFI neighbor configuration
no Negate a command or set its defaults
shutdown Shutdown VFI
status Pseudowire status capabilities
vpn VPN configuration
R6(config-vfi)#bridge-domain ?
<1-4094> Bridge Domain vlan ID value
R6(config-vfi)#bridge-domain 2001 vlan ?
R6(config-vfi)#bridge-domain 2001 vlan
R6(config-vfi)#
|||||
4- What is the use of VC type 4 cause as I understand the service delimiter tag or dummy tag that is added if packets are receievd from AC untagged are only local significant ; i.e. both ends may you different tags !
Am I missing something
|||||
5- In XR what is the difference between "transport-mode vlan" & "transport-mode vlan passthrough" ?
I believe with passthrough no dummy tag will be added in case packets received from AC untagged so in this case packets will be sent to PW without any tag. As I know If packets received from AC untagged and VC Type is 4, a dummy tag is added before packet being send to PW/MPLS
Am I correct ?
l2vpn
pw-class PW-CLASS-TEST
encapsulation mpls
transport-mode vlan
l2vpn
pw-class PW-CLASS-TEST
encapsulation mpls
transport-mode vlan passthrough
Many Thanks
Regards
Sherif Ismail
11-22-2013 12:54 AM
Hi Sherif
1)
rewrite ingress tag pop 1 symmetric command remove 1st upper tag from the packet it receives. In your case VLAN tag 100 is received on this interface it will be put into service instance 100. Since the incoming tag no longer has any inherent meaning beyond this specific interface we need a way to discard that tag before forwarding the frame on. The rewrite ingress command does just that.
Read this in detail for more clarification
https://supportforums.cisco.com/docs/DOC-21299
2) I need to look at 2nd question, will come back to you on later
3) As per my understanding, If you have packet coming from different VLAN, then you need to use this command.
4) VC Type 4 is used for Ethernet VLAN mode, you configure xconnect on a dot1q subinterface, look this for more detail
http://tools.ietf.org/html/draft-ietf-pwe3-ethernet-encap-10#page-8
5) You are correct, if you do not want dummy tag then use passthrough command
Hope this helps
Regards,
Sandip
11-22-2013 10:31 AM
Hi Sandeep
Many thanks for your reply & assistance
l- so this means without popping tag packet would have 2 tags with same value Correct ?
If my understanding is correct then this type of configuration (without popping tag) would be needed in case of Q-in-Q
Hope my understanding is correct:)
2- I believe in case if no
specific global commands
configured for EVC as lmi
or Uni count then both
options would be the same .. that would be my guess
:)
3-But why traffic from other VLAN would match as "xconnect vfi" is configured only under my concerned vlan
4- my last quetion please how when I dummy tag is added (in case packets received are untagged and vc type is 4 and passthrough is not configured) how would remote router translate this dummy vlan to the correct vlan
Many thanks in advance
Sherif Ismail
11-22-2013 12:40 PM
Hi Sherif,
1. Refer section 802.1Q Tunneling (QinQ) in below document, I hope this will clarify your doubt, if still not, let me know
2. I thik so, but not 100% sure, I need to deep dive into this
4.
Without EVC on IOS (pure dot1q on subinterface) :
Consider: CE1 ---- PE1 ------[ ~ MPLS CORE ~ ]------PE2 ---- CE2
The incoming VLAN tag from CE1 is removed, dummy VLAN tag of 0 is
added while it traverses the MPLS core.
However ,when the remote PE2 is reached, the dummy tag is removed,
the tag being imposed is based on the dot1q VLAN configured on CE2.
So, even if CE1 and CE2 are in different VLAN's the tag rewrite process happens
automatically and traffic flows transparently across disparate VLAN's.
With EVC on IOS:
"rewrite ingress tag symmetric" needs to be configured on EVC for end-end
connectivity exists across disparate VLAN.
Regards,
Sandip
11-25-2013 05:58 AM
Hi Sandip
Many thanks for your detailed reply
1- The document is great and really helped
For QinQ method 2 (P.11-19), method 2 should be similar to figure 11-10 (P.11-28) however I believe there is a small mistake
For the direction EVC --> switchport
Packet received with C-VLAN 20 (encapsulation should be 20 and not 10) then bridge over brigde-domain 10 and at egress of switchport VLAN equals to that of bridge-domain (S-VLAN) is pushed
For the direction switchport --> EVC
C-VLAN Packets received on switchport trunk will have their outer vlan popped (vlan 20) and then bridged to bridge-domain 10. Packets will reach EFP port with only 1 VLAN (C-VLAN 20) and cause there is no rewrite tag operation
If my analysis is correct, then as mentioned encapsulation should be 20
|||
2- If I understood correctly, behavior seems to look as below
For non EVC IOS VC type 4, incoming VLAN tag is removed and dummy tag 0 is added. On remote side this dummy tag is removed and VLAN configured on interface is added
For EVC & IOS XR VC type 4, dummy tag is added on top of incoming tag so packet is sent with both tags. With pass-through no dummy tag is added
Thanks
Regards
Sherif Ismail
12-02-2013 09:13 AM
Hi Sherif,
Sorry for delay, got stuck in some urgent works
Your understanding is correct (not sure about IOS XR VC type 4)
Regards,
Sandip
12-03-2013 01:45 AM
Many thanks Sandip for your assistance .. Much appreciated
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide