cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
21341
Views
5
Helpful
16
Replies
Highlighted
Participant

Help with setting up Metro Ethernet

Can someone please help and give suggestions and possible configuration options for setting up metro ethernet in the following senario:

Will be setting up ME between headquarters and three remote branch offices. Each remote branch will be provisioned to 10MB, and the headquarters will have one link for the aggregate provisioned to 30MB.

My questions, we will have routers at the remotes, but how will this terminate at the headquarters? Do we connect the one ME aggregate connection to a router, or to a L3 switch? And how do you configure the headquarters devices to separate the traffic? Do you use sub interfaces like in frame relay? Please provide a sample config if possible.

Thanks

16 REPLIES 16
Highlighted
Rising star

Re: Help with setting up Metro Ethernet

HI,

but how will this terminate at the headquarters?

A. Terminate the ME links at the L3 Switch and configure the Sub-interface in the Router.

how do you configure the headquarters devices to separate the traffic?

A. You can use Cisco MPLS-VPN Technology. Refer useful link below:

http://www.cisco.com/en/US/docs/net_mgmt/vpn_solutions_center/1.1/user/guide/VPN_UG1.html

Pls Rate if HELPS

Best Regards,

Guru Prasad R

Highlighted
Participant

Re: Help with setting up Metro Ethernet

So at the headquarters end I will bring the ME circuit into say my 6500. At the remotes I will have routers, is it here at the remotes where I will configure the "sub-interfaces"?

Thanks

Highlighted
Rising star

Re: Help with setting up Metro Ethernet

HI,

Assume you have 3560 SW at your HQ and where you can terminate the ME circuts.

Configuration in Switch as:

3560SW#sh run int Fa0/5

Building configuration...

Current configuration : 123 bytes

!

interface FastEthernet0/5

description ***************

switchport access vlan 40

switchport mode access

end

Create a SVI interface at the Router, the configuration is as:

7604-Backbone-RTR#sh run int Vl40

Building configuration...

Current configuration : 119 bytes

!

interface Vlan40

description *********

ip vrf forwarding 1234-NAME-MESH

ip address xx.xx.xx.xx 255.255.255.252

end

In the above configuration, VRF is applied on Interface to make the pefix unique across the Backbone.

is it here at the remotes where I will configure the "sub-interfaces"?

A. Yes, the case for remote is same as that of HQ.

Pls Rate if HELPS

Best Regards,

Guru Prasad R.

Highlighted
Participant

Re: Help with setting up Metro Ethernet

This helps, but one area I am uncertain of is with the configuration at the heaquarters L3 switch. When I connect the ME circuit into my 6500, how will I define the separation in traffic between my remove sites? In the configuration above it has a simple switchport configuration for the headquarters switch. If the ME circuit is HUB and spoke like "see attachment" how will at the headquarters define the traffic from site 1, site 2, etc...? I know how this works in frame relay with DLCI's, but ME is where I am uncertain in this regard.

Thanks

Highlighted
Rising star

Re: Help with setting up Metro Ethernet

HI,

The requirement looks like HUB & Spoke topology and you want all your Spokes to communicate with the HUB only and no inter-communication between the spoke offices.

You can Ethernet over MPLS between the HQ and Remote Sites. The configuration looks simple over Ethernet Circuit.

HQ Router:

interface GigabitEthernet0/3.xxx

description ****To Site1****

encapsulation dot1Q xxx

no cdp enable

xconnect abc encapsulation mpls

end

Site1 Router:

interface GigabitEthernet0/3.xxx

description ****To HQ****

encapsulation dot1Q xxx

no cdp enable

mpls l2transport route abc

end

Note:

Command: xconnect abc encapsulation mpls

Command: mpls l2transport route abc

end

The above 2' commands are same, the CLI varies in Cisco based on the IOS Software Version.

Hope I am Informative.

Pls Rate if Helps

Best Regards,

Guru Prasad R.

Highlighted
Participant

Re: Help with setting up Metro Ethernet

This, helps. The headquarters devices will be a L3 switch and the remotes will be routers? In the above config you have it as a router. Will this affect the config change? Also would I just add sub-interfaces at the headquarters for each spoke?

Thanks

Highlighted
Rising star

Re: Help with setting up Metro Ethernet

HI,

If it is a L3 Switch @ HQ, create SVI Interface and try for the 'configuration'

1' SVI interface for each remote offices will do.

HTH,

Guru Prasad R.

Highlighted
Participant

Re: Help with setting up Metro Ethernet

Ok, so will that SVI (VLAN interface I am assuming) have to be the same vlan number the provider gives me for each site, if the provider assigns a VLAN number for each remote site? Is this typically the way (AT&T) the provider will do it?

Thanks

Highlighted
Rising star

Re: Help with setting up Metro Ethernet

HI,

Yes, few providers will assign same VLAN No's end-to-end.

It is not mandatory for having the same VLAN No#, however, the VC ID should be same.

Best Regards,

Guru Prasad R.

Highlighted
Participant

Re: Help with setting up Metro Ethernet

So if I have a "hub-and-spoke" ME setup and routers (not switches) at the hub and spoke locations will I have subinterfaces on the hub router with dot1q for each coresponding vlan and at the remotes the same type of setup?

Thanks

Highlighted
Rising star

Re: Help with setting up Metro Ethernet

Yes, you should have dot1Q enabled at HUB & Spoke sites.

HTH,

Guru Prasad R.

Highlighted

Help with setting up Metro Ethernet

In a similar topology, how do the remote sites connect to the Internet - is it through the HQ site, or does the metro ethernet connection at the branch give you the option to go straight to the Internet?

Highlighted
Beginner

Re: Help with setting up Metro Ethernet

Actually after reading all these responses on this, its actually much easier than you think. (unless I missed something)

Since your doing L3 its very simple. Just create a IP WAN all in the same subnet and you will be good to go since its all on routers.

The Provider should then tag those IP's to route them within their Service Provider network within a vlan to your sites. It will basically be a broadcast network running around within its own vlan so to speak... That end point at your HQ will see all the other locations off that one connection.

Should be a piece of cake, we do this for lots of customers now, as well as provide transparent L2 lan services as well for customers who dont want a L3 WAN but pass all their vlans/broadcast/arp/stp/cdp and other protocols across the wan.

Stuart

Highlighted
Participant

Re: Help with setting up Metro Ethernet

Hi Stuart,

If I post a config snippet example could you tell me if it looks good?

Thanks,

Brandon

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey