cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4500
Views
0
Helpful
4
Replies

Interface BDI doesn't stay up

Hi Team,

 

I have noticed a weird behaviour on my ASR920 routers trying to configure VPLS

 

l2 vfi TWC manual
 vpn id x
 bridge-domain x

!

interface GigabitEthernet0/0/10
 description Test
 no ip address
 negotiation auto
 no keepalive
 service instance x ethernet
  encapsulation untagged
  rewrite ingress tag pop 1 symmetric
  bridge-domain x
 !

 

If I have Vlan x trunked via a Pseudowire and also on an access port (service-instance), unless the access port is physically up, the "interface BDI" stays down even if the Pseudowire is up.

 

I would expect the BDI interface to be up as long as a Pseudowire in that BDI is up. I tried things like "no autostate" and "no keepalive", but these commands are not supported on BDI interfaces on ASR 920.

 

One other thing I noticed is that if I shut down the affected bridge-domain and no shut it, the BDI comes up and stays up indefinitely.

4 Replies 4

esundberg
Level 1
Level 1

Same issue.. Opened tac case  687971242

 

ASR920-24TZ#conf t
ASR920-24TZ(config)#bridge-domain 650
ASR920-24TZ(config-bdomain)#
ASR920-24TZ(config-bdomain)#l2 vfi 10650 manual
ASR920-24TZ(config-vfi)# vpn id 10650
ASR920-24TZ(config-vfi)# bridge-domain 650
ASR920-24TZ(config-vfi)# mtu 9180
ASR920-24TZ(config-vfi)# neighbor 1.1.1.1.96 pw-class VPLS
ASR920-24TZ(config-vfi-neighbor)# neighbor 1.1.1.1.82 pw-class VPLS
ASR920-24TZ(config-vfi-neighbor)# neighbor 1.1.1.1.92 pw-class VPLS
ASR920-24TZ(config-vfi-neighbor)#
ASR920-24TZ(config-vfi-neighbor)#int Gi0/0/1
ASR920-24TZ(config-if)# service instance 1 ethernet
ASR920-24TZ(config-if-srv)# encapsulation default
ASR920-24TZ(config-if-srv)# l2protocol tunnel cdp stp vtp lldp
Configured Platform supported protocols cdp stp vtp lldp
ASR920-24TZ(config-if-srv)# bridge-domain 650
ASR920-24TZ(config-if-srv)#
ASR920-24TZ(config-if-srv)#exit
ASR920-24TZ(config-if)#exit
ASR920-24TZ(config)#exit
ASR920-24TZ#sh mpls l2transport vc vcid 10650

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
VFI 10650 vfi 1.1.1.1.82 10650 DOWN
VFI 10650 vfi 1.1.1.1.92 10650 DOWN
VFI 10650 vfi 1.1.1.1.96 10650 DOWN

ASR920-24TZ#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ASR920-24TZ(config)#bridge-domain 650
ASR920-24TZ(config-bdomain)#shut
ASR920-24TZ(config-bdomain)#no shut
ASR920-24TZ(config-bdomain)#end
ASR920-24TZ#sh mpls l2transport vc vcid 10650

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
VFI 10650 vfi 1.1.1.1.82 10650 UP
VFI 10650 vfi 1.1.1.1.92 10650 UP
VFI 10650 vfi 1.1.1.1.96 10650 UP

ASR920-24TZ#

Great, thanks! Please report back with what they tell you.

tech.linkwave
Level 1
Level 1

HI ANy update ? what they said and how you fixed the issue 

This is expected behaviour and there's no "fix" to this. Our main problem was that we allocated a BDI on each router to manage it over the VPLS and we wanted to have it UP all the time. The only way to guarantee that some BDI is UP all the time is to not allocate any physical port to that BD. If done like that, the BD and BDI always stay UP