cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2136
Views
0
Helpful
7
Replies

L2 qos on ES20 linecard

Johny1975
Level 1
Level 1


I have the following policy in a L2 ethernet trunk interface :


policy-map policy-1

  class cos-1

    priority 10

  class cos-2

    bandwidth percent 20

  class cos-3

    bandwidth percent 40

  class class-default

    bandwidth percent 30


interface GigabitEthernet0/4

switchport mode trunk    

switchport trunk allowed vlan 20,30,40

service-policy output policy-1

I want to translate it for an es20 service-instance mode interface like this :

interface GigabitEthernet3/0/13
 mls qos trust cos
 service instance 1 ethernet
  encapsulation dot1q 20
  rewrite ingress tag pop 1 symmetric
  bridge-domain 20
 !
 service instance 2 ethernet
  encapsulation dot1q 30
  rewrite ingress tag pop 1 symmetric
  bridge-domain 30
 !
 service instance 5 ethernet
  encapsulation dot1q 40
  rewrite ingress tag pop 1 symmetric
  bridge-domain 40
 !

The problem is that i cant apply a policy on the main interface if i have configure service instances.

How can i share the bandwidth between service instances?

7 Replies 7

Johny1975
Level 1
Level 1

If ethernet frames of vlan 20 have cos value 1,

                           of vlan 30 have cos value 2,

                           of vlan 40 have cos value 3

I want to share the bandwidth of the main interface to the service instances :

service instance 1 bandwidth 10% with priority,

service instance 2 bandwidth 20% ,

service instance 3 bandwidth 40% ,

service instance 4 bandwidth 30%

Hi George,

ES20 doesn't support qos policy on main interface when service instances or sub-interfaces are configured.

The policy has to be directly applied on the service-instance or sub-interface.

In other words service policies on L3 interfaces and L2 service instances are mutual exclusive.

There is no plan to make this available in future releases.

Maybe you can configure a similar policy and apply it to each service instance (Ok, this will not get the same result).

something like the following applied to each service instance:

policy-map policy

  class cos-1

   police 256000  *

    priority

  class cos-2

    bandwidth percent 20

  class cos-3

    bandwidth percent 40

  class class-default

    bandwidth percent 30

* LLQ is supported along with policing only.

Or you need to make the Es20 port a switchport as it was on the other box/card even though I would keep the EVC config which allows you

to configure more staff (beside this type of QoS  )

regards,

Riccardo


little addendum; if you get an ES+ card you might configure service groups QoS which might get your goal.

Riccardo

There is a feature on the SRE version that group the service instances, the evc-group :

http://www.cisco.com/en/US/docs/routers/7600/install_config/ES20_config_guide/bald_qos.html#wp1453539

Thank you for your reply Riccardo!

indeed on SRE we have service-groups (the feature I mentioned) for Es20 too.

I tried it and it works fine.

Riccardo

Hi,

It can also be acheived without using service groups as follows:

policy-map child-vlan10

class class-default

  priority

  police 10000000

  queue-limit

!

policy-map parent-vlan10

class class-default

  shape average 990000000

  bandwidth remaining ratio 10

  service-policy child-vlan10

!

policy-map child-vlan20

class class-default

  bandwdith percent 20

  queue-limit

!

policy-map parent-vlan20

class class-default

  shape average 990000000

  bandwidth remaining ratio 20

  service-policy child-vlan20

!

policy-map child-vlan40

class class-default

  bandwidth percent 40

  queue-limit

!

policy-map parent-vlan40

class class-default

  shape average 990000000

  bandwidth remaining ratio 40

  service-policy child-vlan40

!

policy-map child-vlan30

class class-default

bandwidth percent 30

queue-limit

!

policy-map parent-vlan30

class class-default

shape average 990000000

bandwidth remaining ratio 30

service-policy child-vlan30

!

interface gigx/x/x

service instance 1 ethernet

  service-policy output parent-vlan10

service instance 2 ethernet

  service-policy output parent-vlan20

service instance 3 ethernet

  service-policy output parent-vlan40

service instance 4 ethernet

  service-policy output parent-vlan30

!

This will give you more flexibility in future. Specially if you want to clasify more COS values per service instance which will only require to add extra class in the child policies.

Best regards!

I agree with Atif_hafeez

I have also used service groups with success.

However keep in mind usually/hopefully the bandwidth is present in the core network.  Let the core just swap labels.  they will cary any policies you may have presented on packets

Configure all of your policies at the edge.  Ingress/Egress.

Regards

Jude Bryant

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: