I'm having issues trying to get VLAN Bandwidth Limiting to apply only to one particular VLAN. I can get the rate limiting to work on the customer port along with the service provider port, but on the service provider port the rules seem to apply to all VLANS not just the one in particular. When pushing traffic across the VLAN201 in this example, the downstream traffic is limited to 5Mb but should be applied to that VLAN. This is making me scratch my head as to why the rule is applying across all VLANS and not just the 1112 in this example:
class-map match-any vlan_1112
match vlan 1112
!
policy-map LIMIT
class class-default
police cir 5000000
conform-action transmit
exceed-action drop
policy-map UPLINK-LIMIT
class vlan_1112
service-policy LIMIT
interface GigabitEthernet0/11
switchport access vlan 201
media-type rj45
speed 100
!
interface GigabitEthernet0/12
switchport access vlan 1112
service-policy input LIMIT
!
interface GigabitEthernet0/13
description Switchport Trunk to ASR9K
port-type nni
switchport trunk allowed vlan 100,1112
switchport mode trunk
service-policy input UPLINK-LIMIT
Thanks
Bob