cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1938
Views
0
Helpful
1
Replies

Something wrong in the "BASIC" VPLS configuration...

Mario Rosi
Level 1
Level 1

Hi, 

i configured on two PEs the VPLS with this configuration (IOS XE):

 

PE1:

 

interface Loopback0
description IGP-mBGP-MPLS Backbone Interface
ip address 5.100.237.8 255.255.255.255
no ip redirects
no ip proxy-arp

!

...

l2vpn vfi context BD100
vpn id 100
autodiscovery bgp signaling ldp

!

...

interface GigabitEthernet5
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation untagged
bridge-domain 100
!
...

router bgp 10
bgp log-neighbor-changes
neighbor 5.100.237.20 remote-as 10
neighbor 5.100.237.20 update-source Loopback0
!
address-family l2vpn vpls
neighbor 5.100.237.20 activate
neighbor 5.100.237.20 send-community both
exit-address-family
!

...

 

PE2

 

interface Loopback0
description IGP-mBGP-MPLS Backbone Interface
ip address 5.100.237.20 255.255.255.255
no ip redirects
no ip proxy-arp

!

l2vpn vfi context BD100
 vpn id 100
 autodiscovery bgp signaling ldp

!

...

interface GigabitEthernet4
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation dot1q 2
rewrite ingress tag pop 1 symmetric
snmp ifindex persist
bridge-domain 100
!

...

router bgp 10
bgp log-neighbor-changes
neighbor 5.100.237.8 remote-as 10
neighbor 5.100.237.8 update-source Loopback0
!
address-family l2vpn vpls
neighbor 5.100.237.8 activate
neighbor 5.100.237.8 send-community both
exit-address-family
!

 

I know that i'm missing something but i don't know what, anyway, it doesn't work:

 

MPLS_A#sh l2vpn service name BD100
Legend: St=State XC St=State in the L2VPN Service Prio=Priority
UP=Up DN=Down AD=Admin Down IA=Inactive
SB=Standby HS=Hot Standby RV=Recovering NH=No Hardware
m=manually selected

Interface Group Encapsulation Prio St XC St
--------- ----- ------------- ---- -- -----
VPLS name: BD100, State: DN
pw100002 BD100(VFI) 0 DN DN
pw100003 core_pw 5.100.237.20:100(MPLS) 0 DN DN

 

MPLS_A#sh l2vpn vfi name BD100
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: BD100, state: down, type: multipoint, signaling: LDP
VPN ID: 100, VPLS-ID: 10:100
RD: 10:100, RT: 10:100,
Local attachment circuits:
Pseudo-port interface: pseudowire100002
Interface Peer Address VC ID Discovered Router ID S
pseudowire100003 5.100.237.20 100 5.100.237.20 Y

 

...then, if i adopt another configuration template:

 

l2 vfi BD200 autodiscovery
vpn id 200
bridge-domain 200

!

...

interface GigabitEthernet6
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation dot1q 1,3-5
bridge-domain 200
!
!

 

and the same on the other PE, it works.

 

MPLS_A#sh l2vpn service name BD200
Legend: St=State XC St=State in the L2VPN Service Prio=Priority
UP=Up DN=Down AD=Admin Down IA=Inactive
SB=Standby HS=Hot Standby RV=Recovering NH=No Hardware
m=manually selected

Interface Group Encapsulation Prio St XC St
--------- ----- ------------- ---- -- -----
VPLS name: BD200, State: UP
pw100004 BD200(VFI) 0 UP UP
pw100005 core_pw 5.100.237.20:200(MPLS) 0 UP UP

 

MPLS_A#sh l2vpn vfi name BD200
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: BD200, state: up, type: multipoint, signaling: LDP
VPN ID: 200, VPLS-ID: 10:200
RD: 10:200, RT: 10:200,
Bridge-Domain 200 attachment circuits:
Pseudo-port interface: pseudowire100004
Interface Peer Address VC ID Discovered Router ID S
pseudowire100005 5.100.237.20 200 5.100.237.20 Y

 

May you help me finding where is the missing part of coniguration that doens't let VPLS basic configuration to work?

 

Thanks,

Mario

 

1 Accepted Solution

Accepted Solutions

Mario Rosi
Level 1
Level 1

Solved on my own! :)

 

I just adopted the new configuration template via "l2vpn..."

 

Here below the configuration that is working end2end

 

l2vpn vfi context BD100

 vpn id 100

 autodiscovery bgp signaling bgp (or ldp)

!

l2vpn vfi context BD200

 vpn id 200

 autodiscovery bgp signaling bgp (or ldp)

!        

!

!

!

!

!

… chain TP-self-signed-3465486605

!

!

!

!

!

!

!

!

license udi pid CSR1000V sn 9ER1HN0WOWY

license accept end user agreement

license boot level ax

diagnostic bootup level minimal

!

spanning-tree extend system-id

!

!

username cisco privilege 15 secret 5 $1$9lx3$ZnV1.vxITFrQZ/kTPtppo1

!

redundancy

bridge-domain 100

 member GigabitEthernet3 service-instance 1

 member GigabitEthernet5 service-instance 1

 member vfi BD100

!

bridge-domain 200

 member GigabitEthernet3 service-instance 5

 member GigabitEthernet6 service-instance 1

 member vfi BD200

!

!

!

!

interface Loopback0

description IGP-mBGP-MPLS Backbone Interface

ip address 5.100.237.8 255.255.255.255

no ip redirects

no ip proxy-arp

isis tag 100

!

interface GigabitEthernet1

description OOB Management

vrf forwarding Mgmt-intf

ip address 10.255.1.236 255.255.0.0

negotiation auto

no mop enabled

no mop sysid

!

interface GigabitEthernet2

description to csr1000v-2

ip address 172.16.0.1 255.255.255.252

ip router isis

 negotiation auto

mpls ip

cdp enable

no mop enabled

no mop sysid

isis network point-to-point

!

interface GigabitEthernet3

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation dot1q 2

  rewrite ingress tag pop 1 symmetric

!

service instance 5 ethernet

  encapsulation dot1q 3-5

!

!

interface GigabitEthernet4

ip address 172.16.1.1 255.255.255.252

ip router isis

 negotiation auto

mpls ip

cdp enable

no mop enabled

no mop sysid

isis network point-to-point

!

interface GigabitEthernet5

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation untagged

!

!

interface GigabitEthernet6

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation dot1q 1,3-5

!

!

router isis

net 49.0001.0051.0023.7008.00

is-type level-2-only

metric-style wide

set-overload-bit on-startup 180

max-lsp-lifetime 65535

lsp-refresh-interval 65000

spf-interval 5 1 50

prc-interval 5 1 50

lsp-gen-interval 5 1 50

no hello padding

log-adjacency-changes

fast-reroute per-prefix level-2 route-map isis-frr-include

fast-reroute remote-lfa level-2 mpls-ldp

passive-interface Loopback0

!

router bgp 10

bgp log-neighbor-changes

neighbor 5.100.237.20 remote-as 10

neighbor 5.100.237.20 update-source Loopback0

!

address-family l2vpn vpls

  neighbor 5.100.237.20 activate

  neighbor 5.100.237.20 send-community both

  neighbor 5.100.237.20 suppress-signaling-protocol ldp (this command should be avoided if LDP is used as signalling)

exit-address-family

 

View solution in original post

1 Reply 1

Mario Rosi
Level 1
Level 1

Solved on my own! :)

 

I just adopted the new configuration template via "l2vpn..."

 

Here below the configuration that is working end2end

 

l2vpn vfi context BD100

 vpn id 100

 autodiscovery bgp signaling bgp (or ldp)

!

l2vpn vfi context BD200

 vpn id 200

 autodiscovery bgp signaling bgp (or ldp)

!        

!

!

!

!

!

… chain TP-self-signed-3465486605

!

!

!

!

!

!

!

!

license udi pid CSR1000V sn 9ER1HN0WOWY

license accept end user agreement

license boot level ax

diagnostic bootup level minimal

!

spanning-tree extend system-id

!

!

username cisco privilege 15 secret 5 $1$9lx3$ZnV1.vxITFrQZ/kTPtppo1

!

redundancy

bridge-domain 100

 member GigabitEthernet3 service-instance 1

 member GigabitEthernet5 service-instance 1

 member vfi BD100

!

bridge-domain 200

 member GigabitEthernet3 service-instance 5

 member GigabitEthernet6 service-instance 1

 member vfi BD200

!

!

!

!

interface Loopback0

description IGP-mBGP-MPLS Backbone Interface

ip address 5.100.237.8 255.255.255.255

no ip redirects

no ip proxy-arp

isis tag 100

!

interface GigabitEthernet1

description OOB Management

vrf forwarding Mgmt-intf

ip address 10.255.1.236 255.255.0.0

negotiation auto

no mop enabled

no mop sysid

!

interface GigabitEthernet2

description to csr1000v-2

ip address 172.16.0.1 255.255.255.252

ip router isis

 negotiation auto

mpls ip

cdp enable

no mop enabled

no mop sysid

isis network point-to-point

!

interface GigabitEthernet3

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation dot1q 2

  rewrite ingress tag pop 1 symmetric

!

service instance 5 ethernet

  encapsulation dot1q 3-5

!

!

interface GigabitEthernet4

ip address 172.16.1.1 255.255.255.252

ip router isis

 negotiation auto

mpls ip

cdp enable

no mop enabled

no mop sysid

isis network point-to-point

!

interface GigabitEthernet5

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation untagged

!

!

interface GigabitEthernet6

no ip address

negotiation auto

cdp enable

no mop enabled

no mop sysid

service instance 1 ethernet

  encapsulation dot1q 1,3-5

!

!

router isis

net 49.0001.0051.0023.7008.00

is-type level-2-only

metric-style wide

set-overload-bit on-startup 180

max-lsp-lifetime 65535

lsp-refresh-interval 65000

spf-interval 5 1 50

prc-interval 5 1 50

lsp-gen-interval 5 1 50

no hello padding

log-adjacency-changes

fast-reroute per-prefix level-2 route-map isis-frr-include

fast-reroute remote-lfa level-2 mpls-ldp

passive-interface Loopback0

!

router bgp 10

bgp log-neighbor-changes

neighbor 5.100.237.20 remote-as 10

neighbor 5.100.237.20 update-source Loopback0

!

address-family l2vpn vpls

  neighbor 5.100.237.20 activate

  neighbor 5.100.237.20 send-community both

  neighbor 5.100.237.20 suppress-signaling-protocol ldp (this command should be avoided if LDP is used as signalling)

exit-address-family

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: