cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
687
Views
0
Helpful
1
Replies
Beginner

Unable to ping across VPLS Vlan

Hi,

 

I am new to VPLS. I am trying to test VPLS in the lab initially. My set up is extremely basic at present.

 

CE1 (3560CG-8) ---- PE1 (3850-12XS-S)----PE2 (3850-12XS-S)----CE2 (3560CG-8)

 

I have followed the instructions on the following Cisco configuration guide for the 3850 running Fuji 16.9.x  3850 VPLS configuration guide 

 

I am banging my head against the wall trying to get it to work. The document is a little bit vague in parts so it would be great to have someone look over my config.

 

The two 3850's are directly connected (they were separated by a router but I have simplified it) and have IP connectivity.

 

MTU's are 9000. I can successfully "ping x.x.x.x size 9000 df-bit" between the PE routers.

 

The VC all looks good as below "show mpls l2 vc det" on switch PE1

 

Local interface: VFI 10 vfi up
  Interworking type is Ethernet
  Destination address: 1.1.1.1, VC ID: 10, VC status: up
    Output interface: Te1/0/1, imposed label stack {16}
    Preferred path: not configured  
    Default path: active
    Next hop: 1.1.1.1
  Create time: 00:02:52, last status change time: 00:00:21
    Last label FSM state change time: 00:00:21
  Signaling protocol: LDP, peer 1.1.1.1:0 up
    Targeted Hello: 1.1.1.2(LDP Id) -> 1.1.1.1, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: No fault
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 16, remote 16 
    Group ID: local n/a, remote 0
    MTU: local 9000, remote 9000
    Remote interface description: 
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  SSO Descriptor: 1.1.1.1/10, local label: 16
  Dataplane:
    SSM segment/switch IDs: 16410/8213 (used), PWID: 1
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0

"show mpls forward" on PE1

 

 

Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop    
Label      Label      or Tunnel Id     Switched      interface              
16         No Label   l2ckt(1)         0             none       point2point 

The following is the relevant config on PE1. Interface T1/0/1 faces PE2 and interface T1/0/2 faces CE1. PE2 and CE2 are configured the same but obviously with different IP addresses.

 

pseudowire-class vpls10
 encapsulation mpls
!
l2 vfi 10 manual 
 vpn id 10
 neighbor 1.1.1.1 pw-class vpls10
!
interface TenGigabitEthernet1/0/1
 no switchport
 ip address 1.1.1.2 255.255.255.0
 ip router isis 1
 mpls ip  
!         
interface TenGigabitEthernet1/0/2
 switchport access vlan 10
 switchport mode access
 mpls ip  
!
interface Vlan10
 no ip address
 xconnect vfi 10

The CE switch has an access port in VLAN 10 facing port T1/0/2 of the PE switch.

 

Am I doing something fundamentally wrong here? Any pointers or suggestions gratefully received.

 

Thanks,

 

Marty

 

 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Unable to ping across VPLS Vlan

it turns out that my issue was due to not using loopback interfaces. Although that is not specifically mentioned in the document. It is essential for it to work. I hope that helps someone else!

View solution in original post

1 REPLY 1
Highlighted
Beginner

Re: Unable to ping across VPLS Vlan

it turns out that my issue was due to not using loopback interfaces. Although that is not specifically mentioned in the document. It is essential for it to work. I hope that helps someone else!

View solution in original post

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here