Showing results for 
Search instead for 
Did you mean: 

Problem with CMX Mobile App Server


I am working to develop an Android app by using MSE v8.0. I have a problem with my CMX App server intalled on the FEDORA 21 Beta. As I displayed on the image, I could not run the App Server SDK service. It seems as "NOT ENABLED" or an ERROR message showed time time. I have synchronized cmx mobile app server with MSE but it is not sending any coordinate info to my mobile app or my application can not register to the server. What could be reason for this or any suggestion to solve this would be very helpful.





One possible reason could be because of the Firewall services running in the Linux on your MAS server. Disable the firewall and restart the MAS services.

Check this link for disabling firewall in Linux: How To: Disable Firewall on RHEL / CentOS / RedHat Linux





Thank you for your advice but I have tried it before but it did not work.


Cisco Employee


1. Have you added your MAS server to the MSE in the Context Aware Service menu item in the MSE ? Have you synced your MSE to the MAS server using Connect and Engage in the MSE ?

2. Are your APs properly synced to your controller in your PI ? Is the NMSP status active between the controller and the MSE in your PI ?

3. Under the /opt/cmx-mobile-app-server/bin in your MAS server, can you run the getServerStatus and getServerStats scripts. When you run the getServerStats script can you check if you are receiving movement events, association events. Else if the total count is 0, can you check if you are receiving unauthorized events.

4. If you stop and restart your mobile app server do you get any error message ? BTW, you do not need the app server apache sdk service for receiving events in the MAS from the MSE.

These steps will help you figure out where the error is between the AP - Controller - MSE - MAS connection.


Abhishek Bhattacharyya


First of all I appreciate your help. I have followed and tried to perform steps as you described above.

For the item;

1. I have added my MAS server to the MSE and synced it to the Connect and Engage in MSE. I can see the notification statistics summary in Context Aware Service .  An increasing number is displayed there as Total Count .

2. NMSP status of the WLC is displayed as active and I can see the AP in PI actively.

3.When I run the getServerStats script, It shows Tracked Associated Clients field a valid number but rightafter Failure getting server stats error message is displayed.

4. When I restart my MAS server, It complates the starting successfully. However, the last service displayed as "NOT ENABLED" .

Thank you for your help.


In regards to 3. When you run the getServerStats count are you getting any unauthorized events ? There should be an unauthorized event counter displayed .

5. Is your mobile device connected to the ssid synced to the MSE ?

6. When you do registration through your mobile application, can you do tail -f /opt/cmx-mobile-app-server/logs/cmx-mobile-app-server.log | grep -i 'registration' on your MAS server and see if any message is displayed or not. If your registration request did reach the mobile app server, it should get printed in the logs. 

Abhishek Bhattacharyya
Content for Community-Ad

This widget could not be displayed.