cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12255
Views
15
Helpful
11
Replies
Highlighted
Beginner

Address family ipv6 vrf ...

Hi,

Please help, I try to configure IPv6 on MPLS (MP-BGP) with command address-family ipv6 vrf <Vrf Name> but failed to capture the following results

#address-family ipv6 vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6


#address-family ipv6 unicast vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6

I have activated the configuration as ipv6 unicast-routing, ipv6 cef, etc

ip vrf Test_IPv6
description **** Test BGP IPv6 ****
rd 776:776
route-target export 776:776
route-target import 776:776

whether there is a lack of configuration?

11 REPLIES 11
Highlighted
Cisco Employee

Re: Address family ipv6 vrf ...

Hi Revai,

For 6VPE, you need to use vrf definition. See below for exampla,

vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv6
exit-address-family
!
!
end

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv6 vrf TEST2
R2(config-router-af)#

HTH,

Nagendra

Highlighted
Hall of Fame Cisco Employee

Re: Address family ipv6 vrf ...

Hello Nagendra,

Thank you for responding. By the way, if you define a VRF using the vrf definition command, is that VRF usable both for IPv4 and IPv6 interfaces, or do I have to configure a VRF separately for IPv4 and IPv6 address families?

Best regards,

Peter

Highlighted
Cisco Employee

Re: Address family ipv6 vrf ...

Hi Peter,

"vrf definition" is generic way of configuring VRF. By enabling required address-family, you can use it for both IPv4 and IPv6 as below,

vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
!
end

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
% Topology TEST2::VPNv4 Unicast::base is currently being deconfigured.


R2(config-router)#vrf definition TEST2
R2(config-vrf)#address-family ipv4
R2(config-vrf-af)#router bgp 100              
R2(config-router)#address-family ipv4 vrf TEST2
R2(config-router-af)#end
R2#
R2#

Highlighted
Cisco Employee

Re: Address family ipv6 vrf ...

Hi,

Sorry about the error message. Please see below for example,

Current configuration : 145 bytes
vrf definition TEST2
rd 123:123
route-target export 123:123
route-target import 123:123
!
address-family ipv6
exit-address-family
!
!
end

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#address-family ipv4 vrf TEST2
% Invalid address family ipv4 unicast vrf TEST2
R2(config-router)#vrf definition TEST2
R2(config-vrf)#address-family ipv4
R2(config-vrf-af)#router bgp 100              
R2(config-router)#address-family ipv4 vrf TEST2
R2(config-router-af)#end
R2#

HTH,

Nagendra

Highlighted
Hall of Fame Cisco Employee

Re: Address family ipv6 vrf ...

Hi Nagendra,

Thank you very much for the explanation. Regarding the error message, no problem, I found that actually quite instructive.

Best regards,

Peter

Highlighted
Beginner

Re: Address family ipv6 vrf ...

Hi Nagendra,

Thanks for your respond, I've try again using configuration vrf definition .. but still failed and still the same result. may I know the IOS and router type are you using? may be for your information, I use a router Cisco 7600 series with IOS c7600s72033-advipservicesk9-mz.122-33.SRD5.bin.

vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776

#address-family ipv6 vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6


#address-family ipv6 unicast vrf Test_IPv6
% Invalid address family ipv6 unicast vrf Test_IPv6

Highlighted
Cisco Employee

Re: Address family ipv6 vrf ...

Have you enabled "address-family ipv6" under vrf definition?.

Please paste "show run vrf "

Regards,

Nagendra

Highlighted
Beginner

Re: Address family ipv6 vrf ...

Hi Nagendra,

Please see below..

#sh run vrf IPv6_Test
Building configuration...

Current configuration : 108 bytes
vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776
!
end

Highlighted
Cisco Employee

Re: Address family ipv6 vrf ...

Hi Gilang,

Can you try the below configuration,

R2(config)#vrf definition IPv6_Test
R2(config-vrf)#rd 776:776
R2(config-vrf)#route-target both 776:776
R2(config-vrf)#address-family ipv6 ==> This appears to be missing in your configuration.
R2(config-vrf-af)#end

R2#show run vrf IPv6_Test
Building configuration...

Current configuration : 149 bytes
vrf definition IPv6_Test
rd 776:776
route-target export 776:776
route-target import 776:776
!
address-family ipv6
exit-address-family
!
!
end

R2#

HTH,

Nagendra

Highlighted
Rising star

Re: Address family ipv6 vrf ...

Hi

You have to use the command "mls ipv6 vrf" before configuring ipv6 address-family.

mls ipv6 vrf

vrf definition Test_IPv6

rd xxx

route-target both  xxx

address-family ipv4

address-family ipv6

You can also have different route-targets for ipv4 and ipv6 like this

mls ipv6 vrf

vrf definition Test_IPv6

rd xxx

address-family ipv4

route-target bo 1:1

address-family ipv6

route-target bo 2:2

or running multicast like this

mls ipv6 vrf

vrf definition Test_IPv6

rd xxx

route-target xxx

address-family ipv4

mdt default 239.1.2.3

address-family ipv6

/Mikael

Highlighted
Beginner

Re: Address family ipv6 vrf ...

Problem has been solved, thanks for all respond

Regards,

Gilang RIvai

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey