cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
913
Views
0
Helpful
6
Replies
Beginner

EoMPLS on 6500s that are vtp servers

I need layer 2 from DC to DC and Im in the home stretch and it wont let me do the vlan I need because my cats are vtp servers.

Is there a way to use an extended vlan number for the sub-interface encapsulation and trick my standard vlan number to traverse that VC?

I have the VC up and working on as if it was vlan 1199 and I really need it to be 199

interface GigabitEthernet11/8

description Gig Link

bandwidth 1000000

ip address 10.61.3.1 255.255.255.252

tag-switching ip

!

interface GigabitEthernet11/8.199

encapsulation dot1Q 1199 <----will not accept normal vlan range

xconnect 10.61.254.3 199 encapsulation mpls

WIL_CR_Core-1A# show mpls l2transport vc                           

Local intf     Local circuit        Dest address    VC ID      Status   

-------------  -------------------- --------------- ---------- ----------

Gi11/8.199     Eth VLAN 1199        10.61.254.3     199        UP       

WIL_CR_Core-1A#

any creative workaround would be greatly appreciated.

6 REPLIES 6
Cisco Employee

EoMPLS on 6500s that are vtp servers

Hi Scott,

Unfortunately, there is not much you can do as VTP will prevent you from using the VLAN range 1-1000 for L3 subinterfaces. I see 3x solutions:

- Configure VTP in transparent mode but I guess it's not doable in your case otherwise you would not have created this post ;-)

- Make sure the traffic is received with a double tags. First one is 1199 and second one is 199. If the PW is VC-type 5 then 1199 is consider as Service-delimiter and will be removed before the traffic is forwarded into the PW.

- Upgrade the HW with ES+ LC so you could use EFP framework to do VLAN translation.

HTH,

Laurent.

Beginner

EoMPLS on 6500s that are vtp servers

tried transparent for giggles. Can do that because vlan 199 is a routed SVI. Basically it looks like the only way to accomplish this is to hang a 3750 off the 6500 on each side.

So its kinda a dead issue.

Now im trying to make it work from 7304 to 7304 across my provider mpls cloud, and that isnt going well either.

Cisco Employee

EoMPLS on 6500s that are vtp servers

If you provide more info about the toplogy and configuration, we may be able to help you regarding your issue between the 2x 7304.

Thanks,

Laurent.

Highlighted
Beginner

EoMPLS on 6500s that are vtp servers

each 7304 connects to an MPLS cloud via an ATM interface (OC3) and I actually have MPLS working but I cannot get the l2 vc up. Core - 7304 - mpls cloud - 7304 - core

G0 - 7304 - atm 4/0

I believe its due to placement of the sub interface, but options are limited.

interface GigabitEthernet0

description ### Uplink ###

ip address 10.61.90.5 255.255.255.0

ip policy route-map Wookie

negotiation auto

mpls ip

!

interface GigabitEthernet0.199

encapsulation dot1Q 199

mpls ip

xconnect 10.60.254.142 199 encapsulation mpls

DAY_CR_WR01#show mpls ldp neighbor

    Peer LDP Ident: 10.60.254.142:0; Local LDP Ident 10.61.254.4:0

        TCP connection: 10.60.254.142.646 - 10.61.254.4.43776

        State: Oper; Msgs sent/rcvd: 8642/8681; Downstream

        Up time: 5d00h

        LDP discovery sources:

          Tunnel66, Src IP addr: 10.60.66.1

          Tunnel67, Src IP addr: 10.60.67.1

        Addresses bound to peer LDP Ident:

          10.60.1.54      10.60.11.1      68.136.12.158   12.113.14.14   

          10.60.254.142   10.60.254.242   10.60.66.1      10.60.67.1     

DAY_CR_WR01#show mpls l2 sum

Destination address: 10.60.254.142, total number of vc: 1

  0 unknown, 0 up, 1 down, 0 admin down, 0 recovering

DAY_CR_WR01#show mpls l2 vc detail

Local interface: Gi0.199 up, line protocol up, Eth VLAN 199 up

  Destination address: 10.60.254.142, VC ID: 199, VC status: down

    Output interface: none, imposed label stack {}

    Preferred path: not configured 

    Default path: no route

    No adjacency

  Create time: 02:14:02, last status change time: 01:12:47

  Signaling protocol: LDP, peer 10.60.254.142:0 up

    MPLS VC labels: local 229, remote 236

    Group ID: local 0, remote 0

    MTU: local 1500, remote 1500

    Remote interface description:

  Sequencing: receive disabled, send disabled

  VC statistics:

    packet totals: receive 0, send 0

    byte totals:   receive 0, send 0

    packet drops:  receive 0, seq error 0, send 0

DAY_CR_WR01#

Cisco Employee

EoMPLS on 6500s that are vtp servers

Hi Scott,

Few comments here:

- mpls should not be configured on the Attachment circuit

- It seems you have an issue with the forwarding path. Do you have an end2end LSP between both 7304 ?

Can you try a traceroute mpls ipv4 10.60.254.142 255.255.255.255 on WR01 and the opposite on the other 7304 ?

Thanks,

Laurent.

Beginner

EoMPLS on 6500s that are vtp servers

stand down the issue has been resolved.

The fix was to toss all the mpls/eompls configurations in the trash and use l2tpv3. Worked flawlessly.

I had actually attempted it first from my 6500's but they wouldnt support it, then eventually somebody in the office suggested L2TP on the 7300's, and it was beautiful

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards