cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
416
Views
5
Helpful
5
Replies

EVPN IRB config on Cisco XE

sachin30720041
Level 1
Level 1

Hello All,

 

I am trying to configure MPLS EVPN IRB on XE router. But ping is not working between ios1 and ios2.

 

ios1----------CSR1--------------CSR2------------ios2

 

ios1
-------------------
int gi0/2
mac-address 0000.1111.1111
ip address 100.10.10.1 255.255.255.0
no sh

 

CSR1
----------------------------
vrf definition red
rd 100:1
!
address-family ipv4
route-target export 100:100
route-target import 100:100
route-target export 100:100 stitching
route-target import 100:100 stitching
exit-address-family
exit

 

interface BDI100
mac-address 0011.0011.0011
vrf forwarding red
ip address 100.10.10.10 255.255.255.0
no sh
exit

 

int gi2
service instance 100 ethernet
encap untagged
exit
no sh
exit

 

int gi1
ip address 100.10.20.1 255.255.255.0
ip ospf 1 area 0
no sh

 

int lo0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
no sh

 

router ospf 1
router-id 1.1.1.1
mpls ldp autoconfig

bridge-domain 100
member gi2 service-instance 100
member evpn-instance 100
exit

 

l2vpn evpn
router-id lo0
replication-type ingress
mpls label mode per-ce
exit

 

l2vpn evpn instance 100 vlan-based

 

router bgp 12
template peer-session session1
remote-as 12
update-source lo0
exit
neighbor 2.2.2.2 inherit peer-session session1
address-family l2vpn evpn
neighbor 2.2.2.2 activate
exit
address-family ipv4 vrf red
advertise l2vpn evpn
redistribute connected
exit-address-family

 

CSR2
--------------------------------
vrf definition red
rd 100:1
!
address-family ipv4
route-target export 100:100
route-target import 100:100
route-target export 100:100 stitching
route-target import 100:100 stitching
exit-address-family
exit


interface BDI100
mac-address 0011.0011.0011
vrf forwarding red
ip address 100.20.20.20 255.255.255.0
no sh
exit

 

int gi2
service instance 100 ethernet
encap untagged
exit
no sh

exit

 

bridge-domain 100
member gig2 service-instance 100
member evpn-instance 100
exit

 

int gi1
ip address 100.10.20.2 255.255.255.0
ip ospf 1 area 0
no sh

 

int lo0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
no sh

 

router ospf 1
router-id 2.2.2.2
mpls ldp autoconfig
exit

 

l2vpn evpn
router-id lo0
replication-type ingress
mpls label mode per-ce
exit

 

l2vpn evpn instance 100 vlan-based
exit

 

router bgp 12
template peer-session session1
remote-as 12
update-source lo0
exit
neighbor 1.1.1.1 inherit peer-session session1
address-family l2vpn evpn
neighbor 1.1.1.1 activate
exit
address-family ipv4 vrf red
advertise l2vpn evpn
redistribute connected
exit-address-family


ios2
-----------------
int gi0/2
mac-address 0000.2222.2222
ip address 100.20.20.2 255.255.255.0
no sh

1 Accepted Solution

Accepted Solutions

Hi @sachin30720041 ,

 

You are correct. It should work even without the L3VPN configuration. You need to add a default gateway on the CEs for it to work though.

 

ios1:

ip route 0.0.0.0 0.0.0.0 100.10.10.10

ios2:

ip route 0.0.0.0 0.0.0.0 100.20.20.20

 

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

what emulator/simulator you using ? ( GNS3 / eve / PNET)

 

Let me review the config now-  mean time can you post below output :

 

#show ip route vrf red  ( from both the CSR)
#show ip interface brief ( from both end IOS device)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

CSR1:-

show ip route vrf red
100.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 100.10.10.0/24 is directly connected, BDI100
L 100.10.10.10/32 is directly connected, BDI100
B 100.20.20.0/24 [200/0] via 2.2.2.2, 00:00:40

 

 

CSR2:-

show ip route vrf red

100.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B 100.10.10.0/24 [200/0] via 1.1.1.1, 00:01:19
C 100.20.20.0/24 is directly connected, BDI100
L 100.20.20.20/32 is directly connected, BDI100

 

IOS1:-


Router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0                           unassigned               YES                    unset administratively down                down
GigabitEthernet0/1                             unassigned             YES                   unset administratively down              down
GigabitEthernet0/2                           100.10.10.1             YES                            manual                   up                   up
GigabitEthernet0/3                             unassigned            YES                    unset administratively  down               down

 

IOS2:-

 


Router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0                              unassigned             YES                 unset administratively down        down
GigabitEthernet0/1                              unassigned             YES                 unset administratively down        down
GigabitEthernet0/2                             100.20.20.2            YES                    manual up up
GigabitEthernet0/3                               unassigned            YES                  unset administratively down          down

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

 

Since ios1 and ios2 use different subnets, you need to enable VPNv4 and redistribute the directly connected subnet for these two end nodes to be able to ping each other.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hello Harold,

 

I am trying to configure EVPN-IRB. Because of MPLS Label2(L3VNI), 2 endpoints even if they are in different subnets, should be able to ping each there. Why do we need to configure vpnv4 address family too ? Where can I find example configuration for EVPN-IRB for XE?

 

Thanks,

Sachin

Hi @sachin30720041 ,

 

You are correct. It should work even without the L3VPN configuration. You need to add a default gateway on the CEs for it to work though.

 

ios1:

ip route 0.0.0.0 0.0.0.0 100.10.10.10

ios2:

ip route 0.0.0.0 0.0.0.0 100.20.20.20

 

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México