cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
529
Views
10
Helpful
2
Replies
Tirzah S G
Beginner

LDP configured on Tunnel interface, neighbor up but no label exchange

Hi!
I have a point-to-point connection from site A to site B and I first enabled MPLS and LDP on the point-to-point interface (the point-to-point link is provided by SP). Because of multicast issue on one side of the link, site-A has shown ldp discovery xmit/recv but site-B shows only xmit on its interface. I added tunnel interfaces on both sides and ran mpls on the tunnel, removed 'mpls ip' from the physical interface and I can see LDP neighborship up and discovery xmit/recv on both sides, however, there is no label exchange. This is driving me nuts. Is it possible that the underlying physical interface should still support multicast traffic for label exchange to happen? If I add mpls IP command back for physical interface in router A and mpls ldp igp autoconfig in router B back again, I can see labels being exchanged, and even though everything looks fine, I can't reach any networks that are connected off of site A from my mpls cloud.

 

sh mpls ldp disc on site B if mpls is ran on interface: 

GigabitEthernet0/0/1.70 (ldp): xmit  (This is because of multicast issue. Hellos can't be received from A, but A can both send & recv)

 

Thanks for your help!

 

UPDATE: This is working after adding routing via tunnel

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Peter,

 

I first tried the targeted LDP session, but it didn't work. I supposed why it didn't work was because of the multicast issue and so moved on to the tunneling option. 

 

Thanks,

Tirzah

View solution in original post

2 REPLIES 2
filopeter
Beginner

To overcome your problem with MPLS LDP neighbor discovery using multicast, you can try to configure targeted LDP session between both routers. Targeted sessions use unicast MPLS LDP hello packets.

In case of tunnel interfaces and missing label exchange, please check if your IGP routing protocol uses the tunnel interface to reach your LDP/IGP neighbor and not the physical interface/subinterface.

Best Regards,

P.

Hi Peter,

 

I first tried the targeted LDP session, but it didn't work. I supposed why it didn't work was because of the multicast issue and so moved on to the tunneling option. 

 

Thanks,

Tirzah

View solution in original post