cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
822
Views
0
Helpful
3
Replies
Highlighted
Beginner

MPLS L2VPN on Cisco CSR

I need single /24 private IP address space that spans two locations across a L2VPN with Cisco CSR 1000v (ax license and vmware vsphere hypervisor)? Tunnel and VC status up but cant connect from location A to location B in same single network. Same config good working in Cisco 2911 but with low performance ~50mbps.

What are the alternatives for the organization of L2VPN / ATOM VPN, to connect the two sites through one network?
What versions of the decision are for localization of a problem with MPLS L2VPN on Cisco CSR and localization of low performance on R2911?     

Config:
    mpls label protocol ldp
    l2vpn
    !
    interface Tunnel0
     ip address 10.1.1.1 255.255.255.252
     ip tcp adjust-mss 1390
     mpls ip
     mpls mtu 1430
     tunnel source 185.3.xx.yy
     tunnel destination 185.25.xx.yy
    !
    interface GigabitEthernet1
     ip address 185.3.xx.yy 255.255.255.0
     negotiation auto
    interface GigabitEthernet2.200
     encapsulation dot1Q 200
     xconnect 10.1.1.2 200 encapsulation mpls
      mtu 1430
    !
    mpls ldp router-id Tunnel0 force

Info:
    csr01#sh mpls l2transport binding
      Destination Address: 10.1.1.2,VC ID: 200
        Local Label:  21
            Cbit: 1,    VC Type: Ethernet,    GroupID: 7
            MTU: 1430,   Interface Desc: n/a
            VCCV: CC Type: CW [1], RA [2], TTL [3]
                  CV Type: LSPV [2]
        Remote Label: 18
            Cbit: 1,    VC Type: Ethernet,    GroupID: 7
            MTU: 1430,   Interface Desc: n/a
            VCCV: CC Type: CW [1], RA [2], TTL [3]
                  CV Type: LSPV [2]
csr01#sh mpls l2transport summary Destination address: 10.1.1.2, total number of vc: 1 0 unknown, 1 up, 0 down, 0 admin down, 0 recovering, 0 standby, 0 hotstandby 1 active vc on MPLS interface Tu0
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Have you told VMWare to allow

Have you told VMWare to allow promiscuous MAC addresses?  Otherwise VMWare will filter them.  This is my first guess at the issue.

Another solution would be to use LISP with host mobility.  Google will give you lots of info on LISP.  Here is one link:

http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Data_Center/DCI/5-0/LISPmobility/DCI_LISP_Host_Mobility/LISPmobile_4.html

View solution in original post

3 REPLIES 3
Highlighted
Advisor

Have you told VMWare to allow

Have you told VMWare to allow promiscuous MAC addresses?  Otherwise VMWare will filter them.  This is my first guess at the issue.

Another solution would be to use LISP with host mobility.  Google will give you lots of info on LISP.  Here is one link:

http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Data_Center/DCI/5-0/LISPmobility/DCI_LISP_Host_Mobility/LISPmobile_4.html

View solution in original post

Highlighted
Advisor

ps. Can you get a link with a

ps. Can you get a link with a larger MTU, such as 1570 (based on your numbers)?  Then you could avoid fragmentation, and you would probably get much more throughput on your 2911.

You could also use a Cisco 4000 series router.   A 4331 is kinda the replacement for the 2911.  Kinda.

http://www.cisco.com/c/en/us/products/routers/4000-series-integrated-services-routers-isr/models-comparison.html

Highlighted

[OFF TOPIC] Hello Philip, I

[OFF TOPIC] Hello Philip, I am sorry for the interruption, but could you please take a look into this question? https://supportforums.cisco.com/discussion/13203876/asr1000-dlci-dlci-l2vpn-using-protocol-based-cli-wrong-documentation

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey