cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1501
Views
0
Helpful
3
Replies
Toomaj Zanguee
Beginner

Routers connected via serial subinterfaces(for non VPN internet service in a mpls network)

I have conected two cisco 7200 routes via one serial interface.

I am going to create two subinterfaces in each of them assign them IP address and connect them via (two BGP neighborship)

the fact is that they cannot even ping eachother though they are directly connected .

1. interfaces are no shut

2.L2 protocol is HDLS on both sides

3.the IPs are in the same subnets .

the question is how to connect two routers with serial sub-interfaces.?

this is my config on both routers , only the IPs are different:

int ser 1/0

no shut

encapsulation hdlc

clock rate 64000

int ser 1/0.1

subif)#ip add a.b.c.d x.x.x.x


3 REPLIES 3
Mohammed Imran Khan
Cisco Employee

Hello Gabriel,

Instead of using the HDLC, use frame-relay encap. Make one side as DCE. Use same DLCI on both sides.

R4#sh run int se2/0

Building configuration...

Current configuration : 96 bytes

!

interface Serial2/0

no ip address

encapsulation frame-relay

frame-relay intf-type dce

end

R4#sh run int se2/0.1

Building configuration...

Current configuration : 113 bytes

!

interface Serial2/0.1 point-to-point

ip address 1.1.1.1 255.255.255.0

frame-relay interface-dlci 100  

end

R4#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms

R4#ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/22/32 ms

R4#sh run | i swit

frame-relay switching

R4#

R5#sh run int se2/0

Building configuration...

Current configuration : 69 bytes

!

interface Serial2/0

no ip address

encapsulation frame-relay

end

R5#sh run int se2/0.1

Building configuration...

Current configuration : 113 bytes

!

interface Serial2/0.1 point-to-point

ip address 1.1.1.2 255.255.255.0

frame-relay interface-dlci 100  

end

R5#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms

R5#ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/44 ms

R5#

Hope this helps.

Regards,

Imran

Thanks Imran Khan . your answer is great  and absolutely right.

thanks for answering very fast .

as I see this is the only thread in the whole internet that solves this issue .

Thanks alot

No Problem Gabriel!

Imran

Content for Community-Ad