cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
793
Views
5
Helpful
2
Replies

Simple VRF+BGP lab not working

mkisielewski
Level 1
Level 1

I have set up a simple lab:

router A - 7200 IOS 12.2(27) JS

router B - 2611

There is a serial link between A and B.

On A the serial interface is in VRF.

The B router has no VRF - just ordinary IP.

I am trying to set up eBGP between them.

But the session does not start.

The A config:

ip vrf v2

rd 7:2

route-target export 7:2

route-target import 7:2

!

ip cef

!

interface Serial2/0

ip vrf forwarding v2

ip address 192.168.25.5 255.255.255.0

!

router bgp 65005

no synchronization

bgp log-neighbor-changes

no auto-summary

!

address-family ipv4 vrf v2

neighbor 192.168.25.2 remote-as 2

neighbor 192.168.25.2 activate

no auto-summary

no synchronization

network 192.168.6.0

exit-address-family

!

I have done some tests:

Ping from B to A works.

Ping vrf from A to B works as well.

telnet from B to A on port 179 gets RST.

telnet /vrf from A to B on port 179 works.

Debug on B shows session establishment attempts, but

with TCP RST response.

Debug on A shows the neighbor is Idle - no attempts.

On A:

sh ip bgp nei

BGP neighbor is 192.168.25.2, vrf v2, remote AS 2, external link

BGP version 4, remote router ID 0.0.0.0

BGP state = Idle

Last read 02:03:54, hold time is 180, keepalive interval is 60 seconds

[...]

Connections established 0; dropped 0

Last reset never

No active TCP connection

I know, that I am new to the VRF stuff, but it is very basic case. What am I doing wrong?

Michal

2 Replies 2

mkisielewski
Level 1
Level 1

I have solved the problem.

The keyword is "bgp router-id".

I had no "normal" interfaces, all were VRF ones.

IOS apparently uses by default only IP address

from "normal" interface as a bgp router ID, so:

#sh ip bgp vpnv4 vrf v2

BGP table version is 1, local router ID is 0.0.0.0

...

As I have forced the ID (bgp router-id ...) all the sessions got up.

Interesting case.

you got it. A usual gotcha for newbies ;-)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: