cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1539
Views
0
Helpful
8
Replies

[SR TE] Tunnel with explicit label path

Carlos A. Silva
Level 3
Level 3

Hi, 

 

I'm testing a topology for an SR TE tunnel. While the tunnel works, it only works when I declared all the labels in the SR path.

 

XE-PE6#show run int tun100
Building configuration...
 
Current configuration : 213 bytes
!
interface Tunnel100
 ip unnumbered Loopback0
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.4
 tunnel mpls traffic-eng path-option 10 explicit name XE-PE3 segment-routing
end

 

ip explicit-path name XE-PE3 enable
index 1 next-label 16003
index 2 next-label 16001
index 3 next-label 16002
index 4 next-label 16004

 

 

These labels are absolute and tied to each hop's looback interface. My question is: is there a way to declare only one of the labels in the path like:

 

ip explicit-path name XE-PE3 enable
index 1 next-label 16003

(the configuration above doesn't bring the tunnel up)

 

So that the tunnel is setup in a way that it only has to pass through PE3, then any other available route?

 

Thanks!

c.

 

 

 

 

8 Replies 8

Harold Ritter
Cisco Employee
Cisco Employee

You should not need to specify all the nodes between the head-end and tail-end. Could you post your ospf or isis configuration.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thanks, Harold. Just so you know, my lab is a mix of XR and XE, but the headend for this particular tunnel is XE.

 

XE-PE6.

segment-routing mpls
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
!
connected-prefix-sid-map
address-family ipv4
10.0.0.6/32 absolute 16006 range 1
exit-address-family
[snip]
!
interface Loopback0
ip address 10.0.0.6 255.255.255.255
ip ospf 1 area 0
!
interface Tunnel100
ip unnumbered Loopback0
tunnel source Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.0.4
tunnel mpls traffic-eng path-option 10 explicit name XE-PE3 segment-routing
!
interface GigabitEthernet1
ip address 10.1.6.6 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
negotiation auto
cdp enable
mpls ip
mpls traffic-eng tunnels
no mop enabled
no mop sysid
!
interface GigabitEthernet2
no ip address
negotiation auto
no mop enabled
no mop sysid
service instance 11 ethernet
encapsulation dot1q 100 second-dot1q 1-4094
!
!
interface GigabitEthernet3
ip address 10.3.6.6 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
negotiation auto
mpls ip
mpls traffic-eng tunnels
no mop enabled
no mop sysid
!
interface GigabitEthernet4
ip address 172.17.0.6 255.255.255.0
negotiation auto
no mop enabled
no mop sysid
!
router ospf 1
router-id 10.0.0.6
segment-routing area 0 mpls
segment-routing mpls
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
[snip]
!
ip explicit-path name XE-PE3 enable
index 1 next-label 16003
index 2 next-label 16001
index 3 next-label 16002
index 4 next-label 16004
!
!
!
!
mpls ldp router-id Loopback0 force
l2vpn xconnect context prueba
member GigabitEthernet2 service-instance 11
member 10.0.0.7 11 encapsulation mpls
[snip]
XE-PE6#

 

 

 

 

XR-P1:

 

 

RP/0/0/CPU0:XR-P1#show run
[snip]
!
hostname XR-P1
[snip]
!
interface Loopback0
 ipv4 address 10.0.0.1 255.255.255.255
!
!
interface MgmtEth0/0/CPU0/0
 vrf mgmt
 ipv4 address 172.17.0.1 255.255.255.0
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.2.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.1.3.1 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 shutdown
!
interface GigabitEthernet0/0/0/3
 ipv4 address 10.1.5.1 255.255.255.0
!
interface GigabitEthernet0/0/0/4
 ipv4 address 10.1.6.1 255.255.255.0
!
interface GigabitEthernet0/0/0/5
 ipv4 address 10.1.100.1 255.255.255.0
!
interface GigabitEthernet0/0/0/6
 ipv4 address 10.1.7.1 255.255.255.0
!
interface GigabitEthernet0/0/0/7
 shutdown
!
route-policy pass
  pass
end-policy
!
router static
 address-family ipv4 unicast
  11.11.11.0/24 Null0 250
  111.111.111.0/24 Null0 250
 !
!
router ospf 1
 log adjacency changes
 router-id 10.0.0.1
 segment-routing mpls
 segment-routing forwarding mpls
 segment-routing sr-prefer
 address-family ipv4 unicast
 area 0
  segment-routing forwarding mpls
  mpls traffic-eng
  segment-routing mpls
  interface Loopback0
   passive enable
   prefix-sid absolute 16001
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/2
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/3
   network point-to-point
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/4
   network point-to-point
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/5
   network point-to-point
   segment-routing forwarding mpls
  !
  interface GigabitEthernet0/0/0/6
   network point-to-point
   segment-routing forwarding mpls
  !
 !
 mpls traffic-eng router-id Loopback0
!
[snip]
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
 interface GigabitEthernet0/0/0/3
 !
 interface GigabitEthernet0/0/0/4
 !
 interface GigabitEthernet0/0/0/5
 !
 interface GigabitEthernet0/0/0/6
 !
!
mpls ldp
 router-id 10.0.0.1
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
 interface GigabitEthernet0/0/0/3
 !
 interface GigabitEthernet0/0/0/4
 !
 interface GigabitEthernet0/0/0/5
 !
 interface GigabitEthernet0/0/0/6
 !
!
[snip]
RP/0/0/CPU0:XR-P1#   

Can you revert back to the configuration where you have only label 16003 in the explicit path and provide the output from "sh mpls traffic-eng tunnels det".

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thanks for taking the time, Harold.

Here’s the capture:

XE-PE6#
*Aug 24 21:08:39.257: %SYS-5-CONFIG_I: Configured from console by console
*Aug 24 21:08:39.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel100, changed state to down
sh mpls traffic-eng tunnels det

P2P TUNNELS/LSPs:

Name: XE-PE6_t100 (Tunnel100) Destination: 10.0.0.4
Status:
Admin: up Oper: down Path: not valid Signalling: Down
path option 10, (SEGMENT-ROUTING) type explicit XE-PE3
Last Error: CTRL:: Explicit path not reaching destination

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
Path Selection:
Protection: any (default)
Path-selection Tiebreaker:
Global: not set Tunnel Specific: not set Effective: min-fill (default)
Hop Limit: disabled
Cost Limit: disabled
Path-invalidation timeout: 10000 msec (default), Action: Tear
AutoRoute: disabled LockDown: disabled Loadshare: 0 [0] bw-based
auto-bw: disabled
Fault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: No
Binding SID: 32

History:
Tunnel:
Time since created: 2 days, 23 hours, 56 minutes
Time since path change: 13 seconds
Number of LSP IDs (Tun_Instances) used: 149
Prior LSP: [ID: 145]
ID: path option 10 [149]
Removal Trigger: configuration changed (severe)
Last Error: CTRL:: Explicit path not reaching destination

P2MP TUNNELS:

P2MP SUB-LSPS:
XE-PE6#

And the output from "sh mpls traffic-eng topology path destination 10.0.0.4 " and "sh mpls traffic-eng topology segment-routing".

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi, Harold:

Just a quick comment. The tunnel does come up if I leave the transit router (that I want) label and the (final)destination label in the explicit-path, while removing all the other hops.
So it looks I would need a minimum of two labels.

Here’s the info you asked for:

XE-PE6#
*Aug 24 22:30:48.320: %SYS-5-CONFIG_I: Configured from console by consolesh mpls traffic-eng topology path destination 10.0.0.4
Query Parameters:
Destination: 10.0.0.4
Bandwidth: 0
Priorities: 0 (setup), 0 (hold)
Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
Min Bandwidth Along Path: 0 (kbps)
Max Bandwidth Along Path: 0 (kbps)
Node Hop Count: 3
Hop 0: 10.1.6.6 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 1: 10.1.7.1 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 2: 10.4.7.7 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 3: 10.0.0.4
XE-PE6#sh mpls traffic-eng topology path destination 10.0.0.4
Query Parameters:
Destination: 10.0.0.4
Bandwidth: 0
Priorities: 0 (setup), 0 (hold)
Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
Min Bandwidth Along Path: 0 (kbps)
Max Bandwidth Along Path: 0 (kbps)
Node Hop Count: 3
Hop 0: 10.1.6.6 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 1: 10.1.7.1 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 2: 10.4.7.7 : affinity 0x00000000, bandwidth 0 (kbps)
Hop 3: 10.0.0.4
XE-PE6#

Hi Carlos,

 

Just a quick comment. The tunnel does come up if I leave the transit router (that I want) label and the (final)destination label in > the explicit-path, while removing all the other hops.

 

Glad to hear it is now working. 

 

So it looks I would need a minimum of two labels.

 

Normally you would need one label for the intermediate node and one of the egress node. 

 

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thanks a lot for taking the time to help out, Harold. I appreciate it.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: