cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2105
Views
0
Helpful
5
Replies
loris.marcellini
Beginner

VPWS-EVPN eBGP?

Hey folks,

I have setup a VPWS-EVPN between two iBGP speakers within AS100:

asr9k-3

router bgp 100
!
address-family l2vpn evpn
!
neighbor 102.102.102.102
remote-as 100
update-source Loopback0
address-family l2vpn evpn
!
l2vpn
xconnect group vpws
p2p vpws-xc
interface GigabitEthernet0/0/0/1
neighbor evpn evi 101 target 101 source 102

 

asr9k-2

router bgp 100
!
address-family l2vpn evpn
!
neighbor 103.103.103.103
remote-as 100
update-source Loopback0
address-family l2vpn evpn
!
l2vpn
xconnect group vpws
p2p vpws-xc
interface GigabitEthernet0/0/0/1
neighbor evpn evi 101 target 102 source 101
!

everything works, at least in theory given that ASRv9000 does not support forwarding plane traffic for l2vpn services (right?). I haven't attached anything to those G0/0/0/1 interfaces (yet) but the xconnect is up

 

RP/0/RP0/CPU0:iosxr-9k-2#sh l2vpn xconnect 
Fri Jan 22 08:01:39.963 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect Segment 1 Segment 2 
Group Name ST Description ST Description ST 
------------------------ ----------------------------- -----------------------------
vpws vpws-xc UP Gi0/0/0/1 UP EVPN 101,102,103.103.103.103 UP

I know this might sound a weird question, however, is there any way such a VPWS-EVP could be setup between different ASes? That is; would I be able to run a eBGP VPWS-EVP?

 

I have tried between AS100 AS300, and given the RT seems to be computed using the local AS, that is DENIED due to RT missed match, here's the output on the PE in AS100:

 

RP/0/RP0/CPU0:Jan 22 08:07:45.612 UTC: bgp[1060]: [default-rtr] (l2evpn): nexthop 101.101.101.101/32, origin i, path 300, extended community RT:300:101 
RP/0/RP0/CPU0:Jan 22 08:07:45.612 UTC: bgp[1060]: [default-rtr] (l2evpn): Received prefix v4Addr:101.101.101.101:101:[1][0000.0000.0000.0000.0000][102]/120 (path ID: none) with MPLS label 24011 from neighbor 101.101.101.101
RP/0/RP0/CPU0:Jan 22 08:07:45.612 UTC: bgp[1060]: [default-rtr] (l2evpn): Prefix v4Addr:101.101.101.101:101:[1][0000.0000.0000.0000.0000][102]/120 (path ID: none) received from 101.101.101.101 DENIED RT extended community is not imported locally

Thanks all in advance,

 

Cheers, L.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Harold Ritter
Cisco Employee

Hi Loris,

 

A couple of things here.

 

1. You are correct that the RT is based on the local ASN. You could work around it by adding the RT to the l2vpn prefixes via an outbound route-policy (add RT:300:101 on the AS100 side and add RT:100:101 on the AS300 side)

 

2. You will need to use "send-extended-community-ebgp" under neighbor x.x.x.x address-family l2vpn evpn, as the extcommunity does not seem to be sent by default.

 

3. Data plane should work depending on the version of XRv9k you use. I am using XRv9k 6.6.2 in my lab and it is working just fine.

 

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

5 REPLIES 5
loris.marcellini
Beginner

Still not sure Anyone?

Hi @loris.marcellini ,

 

Did you have time to review the solution I provided. Let me know if you have any questions.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Harold, sorry I haven't yet. Will provide feedback after trying the
solution you provided.
Harold Ritter
Cisco Employee

Hi Loris,

 

A couple of things here.

 

1. You are correct that the RT is based on the local ASN. You could work around it by adding the RT to the l2vpn prefixes via an outbound route-policy (add RT:300:101 on the AS100 side and add RT:100:101 on the AS300 side)

 

2. You will need to use "send-extended-community-ebgp" under neighbor x.x.x.x address-family l2vpn evpn, as the extcommunity does not seem to be sent by default.

 

3. Data plane should work depending on the version of XRv9k you use. I am using XRv9k 6.6.2 in my lab and it is working just fine.

 

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

Worked as a charm:

 

changes made both sides (example on AS100 side):

 

extcommunity-set rt l2vpn
  100:12
end-set
!
route-policy set-rt
  set extcommunity rt l2vpn additive
end-policy
!
router bgp 100
 neighbor 101.101.101.101
  address-family l2vpn evpn
   send-community-ebgp
   route-policy set-rt out
  !
 !
!
end

 

result:

RP/0/RP0/CPU0:iosxr-9k-2#sh bgp l2vpn  evpn 
Tue May 25 05:54:27.028 UTC
BGP router identifier 102.102.102.102, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 4
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 101.101.101.101:12
*> [1][0000.0000.0000.0000.0000][1]/120
                      101.101.101.101                        0 300 i
Route Distinguisher: 102.102.102.102:12 (default for vrf VPWS:12)
*> [1][0000.0000.0000.0000.0000][1]/120
                      101.101.101.101                        0 300 i
*> [1][0000.0000.0000.0000.0000][2]/120
                      0.0.0.0                                0 i

Processed 3 prefixes, 3 paths
RP/0/RP0/CPU0:iosxr-9k-2#
RP/0/RP0/CPU0:iosxr-9k-2#
RP/0/RP0/CPU0:iosxr-9k-2#
RP/0/RP0/CPU0:iosxr-9k-2#sh l2vpn xconnect 
Tue May 25 05:54:32.355 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
        SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect                   Segment 1                       Segment 2                
Group      Name       ST   Description            ST       Description            ST    
------------------------   -----------------------------   -----------------------------
group-name xconnect-name
                      UP   Gi0/0/0/1              UP       EVPN 12,1,101.101.101.101 
                                                                                  UP    

Thanks !!!