cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6158
Views
0
Helpful
1
Replies
scorpion
Beginner

VRF-Lite using RIP and redistribute connected

Hi,

I am having some problem with VRF-LITE using RIP and redistribute connected. VRF-Lite is configured between a Cisco 7204VXR running

c7200p-advipservicesk9-mz.124-24.T4.bin and a Cisco ME 3400 running me340x-metroipaccess-mz.122-35.SE4.bin. The configurations are as following :

ROUTER-A(7200 VXR)

================

ip vrf A

rd 1:1

route-target export 1:1

route-target import 1:1

!

!

interface GigabitEthernet0/0

description ** INFR - SW1 **

no ip address

duplex full

speed 1000

media-type gbic

negotiation auto

no cdp enable

!

interface GigabitEthernet0/0.11

description ** CLIENT A-VID11 **

encapsulation dot1Q 11

ip vrf forwarding A

ip address 172.16.3.1 255.255.255.252 secondary

ip address 172.16.101.1 255.255.255.252

ip flow ingress

no cdp enable

!

router bgp 38712

!

address-family ipv4 vrf A

  redistribute connected

  redistribute rip

  no synchronization

exit-address-family

!

router rip

!

address-family ipv4 vrf A

  redistribute bgp 65534 metric transparent

  network 10.0.0.0

  network 172.16.0.0

  no auto-summary

  version 2

exit-address-family

ROUTER-B(7200VXR)

================

ip vrf A

rd 1:1

route-target export 1:1

route-target import 1:1

!

!

interface GigabitEthernet0/0

description ** INFR - SW1 **

no ip address

duplex full

speed 1000

media-type gbic

negotiation auto

no cdp enable

!

interface GigabitEthernet0/0.11

description ** CLIENT A-VID11 **

encapsulation dot1Q 11

ip vrf forwarding A

ip address 172.16.102.1 255.255.255.252

ip flow ingress

no cdp enable

!

router bgp 38712

!

address-family ipv4 vrf A

  redistribute connected

  no synchronization

exit-address-family

!

SWITCH-A(ME 3400)

================

ip vrf A

rd 1:1

route-target export 1:1

route-target import 1:1

!

vlan 11

name A

!

interface FastEthernet0/1

description ** INFR - ROUTER **

port-type nni

switchport mode trunk

!

interface FastEthernet0/2

description ** A-BRANCH-1-DATA-L3VPN **

no switchport

ip vrf forwarding A

ip address 10.222.25.129 255.255.255.252

!

interface FastEthernet0/3

description ** A-BRANCH-2-DATA-L3VPN **

no switchport

ip vrf forwarding A

ip address 10.222.25.137 255.255.255.252

!

!

interface Vlan11

description ** A **

ip vrf forwarding A

ip address 172.16.101.2 255.255.255.252

!

router rip

version 2

!

address-family ipv4 vrf A

redistribute connected

network 10.0.0.0

network 172.16.0.0

no auto-summary

version 2

exit-address-family

!

!

!

!

!

end

Output of ROUTER A

===============

Routing Table: A

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 3 subnets

B       172.16.102.0/30 [200/0] via A.B.C.D, 7w0d

C       172.16.101.0/30 is directly connected, GigabitEthernet0/0.11

C       172.16.3.0/30 is directly connected, GigabitEthernet0/0.11

     10.0.0.0/8 is variably subnetted, 2 subnets

R       10.222.25.136/30

           [120/1] via 172.16.101.2, 00:00:11, GigabitEthernet0/0.11

R       10.222.25.128/30

           [120/1] via 172.16.101.2, 00:00:12, GigabitEthernet0/0.11

Output of ROUTER B

===============

Routing Table: A

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets

C       172.16.102.0/30 is directly connected, GigabitEthernet1/0.11

B       172.16.3.0/30 [200/0] via B.C.D.E, 6w5d

B       172.16.101.0/30 [200/0] via B.C.D.E, 3w5d

     10.0.0.0/8 is variably subnetted, 2 subnets

B       10.222.25.136/30 [200/1] via B.C.D.E, 5d06h

B       10.222.25.128/30 [200/1] via B.C.D.E, 5d06h

Output of SWITCH A

==================

Routing Table: A

Gateway of last resort is 172.100.101.1 to network 0.0.0.0

     172.100.0.0/16 is variably subnetted, 2 subnets

R       172.16.102.0/30 [120/1] via 172.16.101.1, 00:00:10, Vlan11

C       172.16.101.0/30 is directly connected, Vlan11

     10.0.0.0/8 is variably subnetted, 2 subnets

C       10.222.25.136/30 is directly connected, FastEthernet0/3

C       10.222.25.128/30 is directly connected, FastEthernet0/2

Now the problem is although there is an IP address 172.16.3.0/30 connected in ROUTER A and I have configured "redistribute connected" in rip but that route is not advertised to the switch. What am I missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Dan-Ciprian Cicioiu
Rising star

Hi,

You could try to disable split-horizont on that interface ;

Router A

interface GigabitEthernet0/0.11

no ip split-horizon

Dan

View solution in original post

1 REPLY 1
Dan-Ciprian Cicioiu
Rising star

Hi,

You could try to disable split-horizont on that interface ;

Router A

interface GigabitEthernet0/0.11

no ip split-horizon

Dan

View solution in original post