cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Announcements
Choose one of the topics below to view our ISE Resources to help you on your journey with ISE

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

1472
Views
3
Helpful
6
Replies
Highlighted
Beginner

ACS 5.3 Cumulative Patch failure

I am having problems installing the ACS 5.3.0.40.9 cumulative patch.  We were able to install the patch on our secondary instance with no problem at all, however we cannot install it on our Primary instance.  I am installing by using the command ...

acs patch install 5-3-0-40-9.tar.gpg repository ACS-PATCH

After the patch downloads, I receive the following error message ...

hostname# acs patch install 5-3-0-40-9.tar.gpg repository ACS-PATCH

Patch '5-3-0-40-9' is already installed.

% Error: Failure to open / validate the patch

One...I know that the patch is NOT installed, as I am the administrator, and I have never successfully installed the patch on this appliance.  And two, when looking at the 'show version' information, I can see the following ...

hostname/user# sh ver

Cisco Application Deployment Engine OS Release: 1.2

ADE-OS Build Version: 1.2.0.228

ADE-OS System Architecture: i386

Copyright (c) 2005-2009 by Cisco Systems, Inc.

All rights reserved.

Hostname: hostname

Version information of installed applications

---------------------------------------------

Cisco ACS VERSION INFORMATION

-----------------------------

Version : 5.3.0.40

Internal Build ID : B.839

As you can see, ".9" is not running, and there is no indication that any patches have been installed.

Anyone else running in to this?  As I said previously, using the same patch file and using the same process on our secondary instance worked flawlessely.

Any ideas?

TIA

6 REPLIES 6
Highlighted
Participant

Hi,

Trying renaming the patch file and then try.

**Share your knowledge. It’s a way to achieve immortality.
--Dalai Lama**

Please Rate if helpful.
Regards
Ed

**Share your knowledge. It’s a way to achieve immortality. --Dalai Lama** Please Rate if helpful. Regards Ed
Highlighted
Beginner

If the filename is not exactly 5-3-0-40-9.tar.gpg you get this error.

Alex.

Highlighted
Enthusiast

can you please try this:

Deregister  the secondary from the primary first, once you have the  two servers as  standalone units you can proceed to upgrade one of the  servers, if it  goes fine then continue with the other one.

Once you have upgraded both units you can register the old secondary back to the old primary.

Highlighted

I am having the same issue while trying to patch to 5-1-0-44-6 before the upgrade to 5.3

I have successfully patched the Primary but having issues with the secondary getting the error below saying its installed when obviously its not.

Patch '5-1-0-44-6' is already installed.

% Error: Failure to open / validate the patch

When I try to remove the patch, I get the error patch not installed confirming the patch isnt installed as below.

XX-ACS01/admin# acs patch remove 5-1-0-44-6.tar.gpg

% Error: Patch 5-1-0-44-6.tar.gpg is not installed.

XX-ACS01/admin# sh ver

Cisco Application Deployment Engine OS Release: 1.2

ADE-OS Build Version: 1.2.0.146

ADE-OS System Architecture: i386

Copyright (c) 2005-2009 by Cisco Systems, Inc.

All rights reserved.

Hostname: XX-ACS01

Version information of installed applications

---------------------------------------------

Cisco ACS VERSION INFORMATION

-----------------------------

Version : 5.1.0.44

Internal Build ID : B.2347

Has anyone been able to solve this issue or do we have to open a case with TAC in order to solve this?

Nkumar, are you talking about upgrading or patching? As I understand, you would only need to deregister and delete the instance when upgrading not when patching. I also understand you need to patch before upgrading.

Kindly expantiate.

Regards

Yomi

Highlighted

Maybe a couple of years late, but I think the syntax it is looking for in the removal would be:

> acs patch remove 5-1-0-44-6

It seems to identify the patches like that.  I would guess that it likes the ".tar.gpg" on a patch installation, but it probably likes just the patch identification on a removal.

Thanks,

Anthony

Highlighted
Beginner

Alex Goldney is correct. Download the file "5.3.0.40.9.tar.gz" and save it in your repository with that name. Then try upgrading