cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Announcements
Choose one of the topics below to view our ISE Resources to help you on your journey with ISE

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

946
Views
5
Helpful
2
Replies
Highlighted
Beginner

Problems installing 5-2-0-26-4.tar.gpg on ACS 5.2

Trying to upgrade a pair of ACS servers from 5.2.0.26 base to patch 4.  I have tried creating different repositiories that are SFTP, FTP, and Local.  The secondary unit(ROTACS2) upgraded fine with no problems the primary(ROTACS) will not, see below.

Cisco Application Deployment Engine OS Release: 1.2
ADE-OS Build Version: 1.2.0.182
ADE-OS System Architecture: i386

Copyright (c) 2005-2009 by Cisco Systems, Inc.
All rights reserved.
Hostname: ROTACS


Version information of installed applications
---------------------------------------------


Cisco ACS VERSION INFORMATION
-----------------------------
Version : 5.2.0.26
Internal Build ID : B.3075

ROTACS/mpartain#

********************************
REPOS.  21.120 is in the same broadcast.


repository acs_sftp
  url sftp://xxx.xxx.21.120/home/acs/
  user acs password hash xxxx
repository acsrepo
  url ftp://xxx.xxx.21.120/
  user acs password hash xxxxx
repository local
  url disk:/patch
  user partainm password hash xxxxxx
repository mikes
  url ftp://144.103.30.23/
  user acs password hash xxxxxx

******************
Interface

ROTACS/mpartain# sh int
eth0      Link encap:Ethernet  HWaddr 00:15:17:E8:27:1D 
          inet addr:xxx.xxx.21.117  Bcast:xxx.xxx.21.127  Mask:255.255.255.240
          inet6 addr: fe80::215:17ff:fee8:271d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5685191 errors:0 dropped:2727 overruns:0 frame:0
          TX packets:4272107 errors:31947 dropped:0 overruns:0 carrier:31947
          collisions:439208 txqueuelen:100
          RX bytes:2010473489 (1.8 GiB)  TX bytes:1347424956 (1.2 GiB)
          Base address:0x2000 Memory:e8180000-e81a0000


*********************
Show repos

ROTACS/mpartain# sh repo acs_sftp
old
5-2-0-26-1.tar.gpg
5-2-0-26-4.tar.gpg
ROTACS/mpartain#

ROTACS/mpartain# sh repo acsrepo
5-2-0-26-1.tar.gpg
5-2-0-26-4.tar.gpg
old
ROTACS/mpartain#

ROTACS/mpartain# sh repo mikes
5-2-0-26-1.tar.gpg
5-2-0-26-4.tar.gpg
ROTACS/mpartain#

ROTACS/mpartain# sh repo local
5-2-0-26-1.tar.gpg
5-2-0-26-4.tar.gpg
ROTACS/mpartain#

****************
ACS Patch Install results
ROTACS/mpartain# acs patch install 5-2-0-26-4.tar.gpg repository local
Invalid patch '5-2-0-26-4.tar.gpg', cannot unpack.
% Error: Failure to open / validate the patch

ROTACS/mpartain#


ROTACS/mpartain# acs patch install 5-2-0-26-4.tar.gpg repository acsrepo
Invalid patch '5-2-0-26-4.tar.gpg', cannot unpack.
% Error: Failure to open / validate the patch

ROTACS/mpartain#


ROTACS/mpartain# acs patch install 5-2-0-26-4.tar.gpg repository acs_sftp
Invalid patch '5-2-0-26-4.tar.gpg', cannot unpack.
% Error: Failure to open / validate the patch

***********************
My thoughts.

It appears that the GPG key is not vaild on this primary server.  The patches are in the repositories and I used the acsrepo repo to install on the ROTACS2 secondary server.

I have looked through articles and the only mention is to not use TFTP, which I am not.  I have also tried to apply patches 1-3 with the same results.

Please help, I have one patched and the other is not.

2 REPLIES 2
Beginner

Re: Problems installing 5-2-0-26-4.tar.gpg on ACS 5.2

Fixed the problem.  It appears that it was something to do with the account I was using.  I logged in with the initial admin account which worked.  Even though the mpartain account had "role admin" it could not install the patch.

Just wanted to post what I have found.  Hope it helps someone in the future.

Mike Partain

Highlighted
Beginner

Hi Mike, Just wanted to say

Hi Mike,

 

Just wanted to say thank you for leaving the comment regarding the "admin vs role admin" account. I was facing the same issue where I was not able to install a software patch using my account with admin privileges.

From the several articles I read trying to solve the issue yours was the only one mentioning the admin account. Once I used the admin user to apply the patch it went on flawlessly.

 

So thanks again for coming back to the post and leaving the user role comment. 

 

 

Jose Ribeiro