Showing results for 
Search instead for 
Did you mean: 

Reimaging a 3495 with the bootable USB method

Tim Steele

Just wanting to see if anyone else has done this yet.  I ran into a couple of interesting snags performing this little ritual over the last day.  First, if you're using CentOS 6.4 (maybe other versions and other distros), the script requires that some syslinux files get copied from /usr/lib on your linux box, but in CentOS 6.4 anyway, those are found at /usr/share.  So, I edited the script accordingly, and things worked fine.  No big deal to use vi to edit that script of course. Maybe some linux gurus can add more detail here for those of us that aren't quite so linux savvy.

Anyway, getting past that (it took about 40 minutes from the time I started the successful run to have a bootable USB), I was able to reimage the first (of seven) 3495 appliances with the bootable USB method.  So, I happily started on the second appliance.  No joy.  After selecting option 1 upon boot, I got stuck at GRUB.  I let it sit for a while but it never moved past that.  I tried another appliance just to be sure and had the same result.  So, I went through the ritual again on a second USB drive (different brand) and sure enough, it worked the first time but would not work with another appliance. 

I used the bootable USB method for two of the appliances, but went with the CIMC method for the rest - and that worked like a champ.  I have a TAC case open to hopefully discover the issue with the bootable USB method.  Any input from others that worked around this would be helpful.  I'll probably always use the CIMC method moving forward, but it would be good to work out the issues with the bootable USB method.


Tarik Admani

If you have connected to the cimc interface you can map the iso from your local machine to the ucs as a virtual cd/dvd. Dont worry abiut hoe mich data is loaded just map it and reboot and follow the installation guide. Saves more time than messing with the bootable usb.

Edit...hahaha should have read the entire post

Sent from Cisco Technical Support Android App


This link will help you to find the installation of the SNS 3400 series.

Thanks, but that doc just spells out how the process is supposed to work.  That is what I was trying to follow to begin with. However, the script that is on the current iso does not look in /usr/share as it needs to on some linux distros. And, I had the problem where I couldn't use the bootable USB drive for more than one appliance.  TAC sent me a new script today that a developer worked on that does provide the ability for the the script to look for the files at /usr/lib OR /usr/share.  He also said the developer tested it on multiple appliances.  I've completed the reimaging of all the appliances for this project so I'll have to wait until my next project involving 3495's to test the new script.

Vincent Fortrat

Hello Tim,

Thanks for your feedback. I also have some errors when launching the script. Could you please share the new script sent by the TAC ?



Here you go Vincent.  I'll keep this link up for a few days.  Please try it out and be sure to post back your results.  Since I had to work though getting all seven 3495's I was working with re-imaged before I got this script, I wasn't able to test it out.  It will be valuable info to know that it works on two fronts: 1) the syslinux files can be obtained no matter which linux distro you are using, and 2) you can re-image more than one appliance with the same bootable USB key.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: