cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2687
Views
4
Helpful
9
Replies
Beginner

ACS 5.0: "Change password on next login" not working?

Hi, all,

I installed my CSACS-1120 appliance running  ACS 5.0, added a user and pointed a device to this ACS server.

When the "Change password on next login" option is unchecked, the  user logs in to the device fine.

But when that option is chcked, I get this on the device:

username:userid
password:

Password: 

% Authentication failed

On the ACS Monitoring and Reports tool, I get these:

7:15:40.706 PM
13030  TACACS+ authentication  request missing a User name





7:15:38.683 PM
13031  TACACS+ authentication  request missing user Passworduserid

Any idea why?

(And why this thing keeps telling me: "You can not post a blank message.  Please  type your message and try again." -- Obviously this message is not  blank! I'll keep typing stuff here till it is accepted.)

Are we there yet?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

Hi,

I just recreated this issue on my lab and the issue is with ACS 5.0 it looks like there is a bug on ACS 5.0 that cause this issue.

I tried with the same aaa client but with a ACS 5.1 and I get the prompt for change the password.

This is a know issue on ACS 5.0.

Thanks,

View solution in original post

9 REPLIES 9
Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

The trick to get a posting through seems to be marking everything  with Ctrl-A, [Edit] cut everything out with Ctrl-X, [/edit] then posting  everything back with Ctrl-V.

I  have to do that little  dance here again. By the way, I am using Firefox  3.6  on Windows XP --  If anyone at Cisco cares.

Highlighted
Hall of Fame Cisco Employee

Re: ACS 5.0: "Change password on next login" not working?

I can't comment on the ACS issue, but I would encourage you to submit feedback if CSC is giving you a problem.  I will also pass this thread on to the CSC admins.  I have had some issues on and off with Epiphany and Camino, but never what you describe.

Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

Thanks, Joe, you have been the most helpful to me on these forums.

Highlighted
Collaborator

Re: ACS 5.0: "Change password on next login" not working?

that's funny; Yesterday, I just read your comment about "You can not post a blank message...." when I tried to post a message to a thread and did get the exactly same message...

I am not sure what solved it at the end but I observed 2 things:

- I was behind a proxy and shortly after this message a pop-up from firefox requests to authenticate with the proxy again

- the window for posting the message was open for a while and before I could finally send the message I had to login to the forum again;

on the "old" forum I had sometimes problems posting a message, so now I usually write my postings in an editor and copy it into the window...

Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

Good observations!

I am also behind a pair of Cisco  IronPort devices that function as proxy/filtering devices.

I  never have to login to the forums again. I only had to do the Ctrl-C,  Ctrl-X, Ctrl-V sequence -- seems to work every time.

Highlighted
Collaborator

Re: ACS 5.0: "Change password on next login" not working?

so perhaps it is a timing issue with the window you opened to post a message?
If this is continuously happening I think it would be easiest to contact the CSC team by using the "Feedback" option on the top of the page...

... but all this does not help with your original problem regarding ACS and I cannot help you with this as I have no system to test....  :-(

Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

Hi,

I just recreated this issue on my lab and the issue is with ACS 5.0 it looks like there is a bug on ACS 5.0 that cause this issue.

I tried with the same aaa client but with a ACS 5.1 and I get the prompt for change the password.

This is a know issue on ACS 5.0.

Thanks,

View solution in original post

Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

I ended up openning a TAC case. The engineer on the case was very   responsive. He quickly reproduced the problem and told me that I had to   upgrade to ACS 5.1.

Now my gripes: The support   engineers are good in this case. But how did a software bug like this   get through in the first place? I know software always have bugs. But  this just seems to suggest software QA at Cisco is some kind of  leisure  affair. Cisco's hardware quality is top notch. But software is a   completely different story.

Highlighted
Beginner

Re: ACS 5.0: "Change password on next login" not working?

Does anyone know the bug ID for this issue? I can't seem to find it using bug toolkit.

Thanks

Mike

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards