cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
835
Views
0
Helpful
3
Replies
Anupam Datta
Beginner

ANIserver not running

We are facing problem with ANI Server which status is showing down. If we manualy restart then its coming up but after few minutes again getting down

the Properties files are attached . Kindly suggest.

ANI .LOg-backup is as follows--

2010/10/27 16:21:27 main ani ERROR ServiceModule: Failed to instantiate com.cisco.nm.ani.server.dfmpoller.NoServiceModule

2010/10/27 16:21:27 main ani MESSAGE DBConnection: Created new Database connection [hashCode = 21514757]

2010/10/27 16:21:27 main ani MESSAGE PartialSMFCommit: Partial Commit is enabled for DataCollection

2010/10/27 16:21:27 main ani ERROR SMFFactoryLoader: java.lang.NullPointerException

2010/10/27 16:21:27 main ani ERROR AniLoadConfiguration: AniStaticConfigException: Error accessing devices--root path null, packageName com.cisco.nm.ani.server.devices

1 ACCEPTED SOLUTION

Accepted Solutions

as it seems the first ANIServer.properties file you posted was the .orig one, the second has commented out line 193 where the DEVICESROOT parameter is set. Stop dmgtd (in a DOS box enter "net stop crmdmgtd" ) when it is stopped, make a backup of the current ANIServer.properties file, then uncomment this line (remove the #) and restart dmgtd (net start crmdmgtd). Wait for 30 mins and see if it is working.

I have attached your file with this change.

View solution in original post

3 REPLIES 3
Anupam Datta
Beginner

THE PROPERTIES FILE

as it seems the first ANIServer.properties file you posted was the .orig one, the second has commented out line 193 where the DEVICESROOT parameter is set. Stop dmgtd (in a DOS box enter "net stop crmdmgtd" ) when it is stopped, make a backup of the current ANIServer.properties file, then uncomment this line (remove the #) and restart dmgtd (net start crmdmgtd). Wait for 30 mins and see if it is working.

I have attached your file with this change.

Thanks A lot its working now