Showing results for 
Search instead for 
Did you mean: 

Can Anyone Tell Me About My Fe0/0 & 0/1 Ports please ?


Hi ...

I have been trying to set up my router for virgin broadband using Fe0/0 for the internet and 0/1 for the internal lan but the trouble i have is even though i have set up the ports and enabled them etc .. i still cant get the lan to work on the internet.

One thing i have noticed is that Fe0/0 will work on dhcp and will get the ip adress from the modem my Fe0/1 will not do dhcp even though it has been set to dhcp.

when you look at the interfaces it shows fe0/0 is dhcp but fe0/1 is nvram ??

can anyone tell me what i am doing wrong here as i have set ip route etc and gateway is set but why no dhcp on fe 0/1 ?

many thanks in advance

4 Replies 4


Ok ... now i have figured it out .. maybe ??

Both ports would operate dhcp if they was to receive an ip address from something providing one ...
which i suppose is the reason why i got an ip from my cable modem ... so all is fine there ...

The reason i am not getting the same from the fe0/1 port is because there is no dhcp server on my lan so it will not get one from anywhere ? im thinking ... so if im wrong please correct me

Thus having to supply a static ip for the fe0/1 meaning any other device would also have to be static on that same lan ??

And the problem of ip interface brief showing 0/0 on dhcp and 0/1 being nvram is due to the config not being saved and the router not being restarted for the settings to change ?

All well and good ... but i need to make my lan on fe0/1 work with my internet on fe0/0 so does that mean i have to set up a Vlan between the two ports ?

Thanks in advance


Anyone ?

Please  ?


Hi Garry,

It sounds lie your virgin modem is possibly also acting as a router.

If you really want to use your cisco you need to setup a static address on your LAN port and also create a dhcp pool. This way your router will dish out IP addresses to your LAN. The static ip must be in a different range to the one that is used by your cable modem. Make sure the dhcp pool gateway is set to the static address on the LAN port.

Also make sure to add a static route to the port the cable modem is connected, eg ip route fe0/0

Google will be your friend



Sent from Cisco Technical Support iPad App



I agree with Scott, just remember if the IP assigned to your fa0/0 is a public IP you might need to also configure nat in your router.


ip nat outside

interface 0/1

ip nat inside

ip nat inside source list 100 interface Fa 0/0 overload

ip route fa0/0

access-list 100 permit ip any any

Hope it works for you,

Rafael Weisson

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers