cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1075
Views
0
Helpful
3
Replies
Highlighted
Beginner

Can not access Inventory - LMS 4.2.5

Hallo,

 

I have the following prolbem. If I access "Inventory->Add/Import/Manage Devices" I got this error:

 

"Error in communication with DCR Server. ..."

 

But the DCR-Server is running.

I have tried something to solve the problem, check some files and the content of these, check hostname. Nothing helps. I have found in the log from CTMJrmServer that the server can not connect to https://<hostname>:443, and so the CTMJrmServer didn't start. But I can not find any reason why.

Logfile:

.

.

.

[ Thu Nov 02  14:38:14 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,getJRM,234,JrmService name JrmServiceManager_netman2
[ Thu Nov 02  14:38:14 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,constructLoginInfo,62,The super user is admin
[ Thu Nov 02  14:38:14 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,constructLoginInfo,63,Get super session...:-(
[ Thu Nov 02  14:38:15 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,constructLoginInfo,109,HOST value for connecting to secret client https://netman2.imed.uni-magdeburg.de:443
[ Thu Nov 02  14:38:15 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,constructLoginInfo,122,COOKIE NULL null
[ Thu Nov 02  14:38:15 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,constructLoginInfo,124,COOKIE NULL 5
[ Thu Nov 02  14:38:15 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,getJRM,255,getJRM: Got exception: java.lang.NullPointerException
[ Thu Nov 02  14:38:15 CET 2017 ],DEBUG,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,getJRM,259,getJRM: Had problems binding to JrmServiceManager. Try no.  2 of 3 - Waiting 10 seconds in between each try.
[ Thu Nov 02  14:38:25 CET 2017 ],FATAL,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,getJRM,271,getJRM:Can't bind to JrmServiceManager. giving up and exiting.

.

.

.

 

Also I can not access dcrcli. I got Authentication failed. Is there any relation?

 

Can anyone help me to solve the problem?

 

Thank you very much for your efforts

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Can not access Inventory - LMS 4.2.5

Hello,

 

so I need LMS everyday (nobody like to see the nothing :-) ), I tried to install a new virtual appliance. If I read the release-notes I found, that is possible to reinstall LMS 4.2.5. I tried it. I clone the appliance and reinstall on the clone without connected to the network (same ipaddress). Everything goes fine and all processes are up after finished. Ok, so I shutdown both aplliances, disconnect the old from network and connect the new to network. Start the new aplliances, same problem. I start the old (without network), all processes are up. :-/

Whatever the reason is, if start the appliance without network-connection, all processes are up. So I delete the new, start the old without network, look on the console that all processes are up. If so, connect the network and all works fine.

View solution in original post

3 REPLIES 3
Beginner

Re: Can not access Inventory - LMS 4.2.5

I have the same problem:

 

Error in communicating with DCR Server. For more details click here.

DCR Server may be down. Please start the DCR Server and then refresh the page.

 

I can't start the DCR Server:

 DCRServer Administrator has shut down this server 

 

The BD is OK

No errors reported
INFO: /opt/CSCOpx/databases/cmf/cmf.db validation complete.

 

I remove all the logs files.

 

Other errors:

 

[LMS/root-ade ~]# pdshow Apache
ERROR: connect to dmgtd process on "127.0.0.1" on port 42340 failed:
[LMS/root-ade ~]# pdshow LMS
ERROR: connect to dmgtd process on "127.0.0.1" on port 42340 failed:
[LMS/root-ade ~]# pdshow
ERROR: connect to dmgtd process on "127.0.0.1" on port 42340 failed:

 

I try to find a solution.

Michel 

Beginner

Re: Can not access Inventory - LMS 4.2.5

Hello,

 

so I need LMS everyday (nobody like to see the nothing :-) ), I tried to install a new virtual appliance. If I read the release-notes I found, that is possible to reinstall LMS 4.2.5. I tried it. I clone the appliance and reinstall on the clone without connected to the network (same ipaddress). Everything goes fine and all processes are up after finished. Ok, so I shutdown both aplliances, disconnect the old from network and connect the new to network. Start the new aplliances, same problem. I start the old (without network), all processes are up. :-/

Whatever the reason is, if start the appliance without network-connection, all processes are up. So I delete the new, start the old without network, look on the console that all processes are up. If so, connect the network and all works fine.

View solution in original post

Beginner

Re: Can not access Inventory - LMS 4.2.5

Hello Michel,

 

it seems, that the daemon-manager not run. Which OS you use for LMS?

 

Ralf

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards