Showing results for 
Search instead for 
Did you mean: 

Cannot connect to ANI Server LMS 4.1

Trey Grun


I saw a few threads insisting this issue is a result of certain ports being blocked but I'm having a difficult time accepting that... the reasoning is...

I get the "1. Unkown hostname 2. Unknown Error" message from a client in the same vlan, same UCS B-Series chassis.  The LMS install is the soft appliance, and the client has had all firewall services disabled.

I'm attempting to start "Topology Services" when I get the error.  What are the other possibilities, and how can I troubleshoot this problem - is there a setting that I missed?  If anyone can suggest a means of resolving and/or troubleshooting the issue, I would appreciate it (can't span switchports, I guess I could try to tcpdump on the soft appliance)

4 Replies 4

Michel Hegeraat
Rising star
Rising star

A few hints:

The LMS server has a hostname. If you do ping hostname on the client does it work?

Try to telnet to the port used by ANI server e.g. telnet hostname  42342.



The LMS server has a hostname, but it is definitely not DNS resolveable.  Interestingly there is a solution to this in the "help" section of LMS:

Launching Topology Services when the Server is not DNS Resolvable

The Cisco Prime LMS client must be able to resolve the hostname of the Cisco Prime LMS server to server's IP Address, through DNS.

If the Cisco Prime LMS server is not DNS resolvable, Cisco Prime LMS client can access it with the IP address itself, by performing the following steps:

  1. Open the file.

  1. Solaris or Soft Appliance: NMSROOT/lib/classpath

Windows: NMSROOT\lib\classpath  where NMSROOT is the directory where you have installed Cisco Prime LMS.

Set the property as follows:  jacorb.dns.enable=off

Go to Admin > Trust Management > Local Server > Certificate Setup.

The Certificate Setup page appears.

Enter the IP Address of the Cisco Prime LMS Server in the Hostname textbox.

Populate the other columns as explained in the Online help for Administration of Cisco Prime LAN Management Solution 4.1.

Click Apply to generate the self-signed certificate.

Restart the daemons. See the Online help for Administration of Cisco Prime LAN Management Solution 4.1 for instructions.

You will be able to launch Topology Services with the IP address itself.

Unfortunately, this procedure did not work.  I restarted the daemons, then restarted the server, then re-checked the new settings on reboot and tried again.  I even closed my browser.  I'm going to clear my java cache, but I'm confused about why it continues to try and connect to a hostname if that setting is now explicitly disabled - because it still reports that ANIServer-7.0-HOSTNAME is not resolveable.


So that documented procedure PLUS deleting my local jar cache (I'm sure that will cause me much misery with other apps soon) solved the problem.  I hope it helps others who cannot utilze DNS due to forces beyond their control.