cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
506
Views
0
Helpful
1
Replies

Cisco 881G IOS 15.4(1)

Mark Bracking
Beginner
Beginner

Equipment:

Cisco Router 881G IOS 15.4(1)   using Static IP Address from ISP

Problem:

DNS is not resolving names & client machines cannot pull HTML web pages or ping Bing.com.

But, I can ping Bing.com from the router using the DNS IP Address provided by ISP  and configured on the router. I have attached the running-config file for your viewing pleasure.

So I need help with correcting the DNS issue

 

Router Configuration File
Building configuration...

Current configuration : 4518 bytes
!

!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WAN-Router
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 ( password removed from view )
enable password 7 ( password removed from view )
!
no aaa new-model
memory-size iomem 10

!
( Key removed from view )
!
        quit
!
!
ip dhcp excluded-address 192.168.100.1 WAN-Router
ip dhcp excluded-address 192.168.100.100 File Server 
ip dhcp excluded-address 192.168.100.252 Air=AG1242
ip dhcp excluded-address 192.168.100.253 CCNA Lab
ip dhcp excluded-address 192.168.100.254 Cisco SG200-18 Core Switch
!
ip dhcp pool local-LAN
 import all
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1
 dns-server 192.168.100.1
 lease 7
 update arp
!
!
!
ip domain name (removed from public view)
ip name-server (ISP IPv4 Address removed from public view)
ip name-server 8.8.8.8
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
license (removed from public view)
license (removed from public view)
!
!
username (removed from public view)
!
!
controller Cellular 0
!
!
interface FastEthernet0
 description MGMT Port
 no ip address
!
interface FastEthernet1
 description LINK TO SG200-18 CORE SWITCH
 no ip address
!
interface FastEthernet2
 description LINK TO AIR-AG1242 WIFI ACCESS
 no ip address
!
interface FastEthernet3
 description LINK TO CiscoCCNALab
 no ip address
!
interface FastEthernet4
 description $ETH-WAN$
 ip address ( Static IPv4 address removed from public view)
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 address autoconfig
 ipv6 enable
!
interface Cellular0
 no ip address
 encapsulation ppp
!
interface Vlan1
 description VLAN1 WAN ROUTER
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
router rip
 version 2
 passive-interface Vlan1
 network 192.168.100.0
 no auto-summary
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-top-talkers
 top 5
 sort-by packets
 cache-timeout 3600
!
ip nat inside source list 101 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 ( Static IPv4 address removed from public view) permanent
ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
!
access-list 101 permit ip 192.168.100.0 0.0.0.255 any
!
banner login ^CThis is a private home network if you have accessed this network
without me providing you with a username and password then you are truspassing and
as such you are required to logout now and never return. ^C
!
line con 0
 exec-timeout 5 30
 login local
 no modem enable
line aux 0
line 3
 no exec
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
!
end

WAN-Router#

1 Reply 1

Mark Bracking
Beginner
Beginner

The problem was the wrong MAC address was assigned to the static IP Address at the ISP sides. Once the MAC STATIC IP issue was resolved the configuration worked great and has every since September 22 that would be 3 months. Open to question

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers