cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1387
Views
20
Helpful
11
Replies
TW80CJ5
Participant

Cisco 9300 Switch Stack IOS

Good Morning!

 

We have switch stack that consists of (2) 9300's. The stack was in bundle mode running 16.12.04.bin. We changed it to install mode that uses the package.conf file and now the version is 16.12.02. 

 

16.12.04 is now an MD stable release.

 

In our downloads center, I dont see where I can download the package.conf file that would upgrade 16.12.02 to 16.12.04.

 

Ideas or suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions
balaji.bandi
VIP Guru

package.conf will be generated automatically, you no need to worry about that.

 

follow upgrade document from 12.02 to 12.04

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-12/release_notes/ol-16-12-9300.html#task_s23_5zf_j3b

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

11 REPLIES 11
balaji.bandi
VIP Guru

package.conf will be generated automatically, you no need to worry about that.

 

follow upgrade document from 12.02 to 12.04

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-12/release_notes/ol-16-12-9300.html#task_s23_5zf_j3b

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

I had some difficulties with the upgrade while in INSTALL Mode. I have the step where it errored and will share when I get back in the office in the morning.

keep us update also post the complete upgrade logs, we have done many but never encounter any issue.

but good to know if something new we can see here and advise.

 

make sure you have enough space in a flash before upgrade, remove any old images from the flash which is not required.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Leo Laohoo
VIP Community Legend

Post the complete output to the following command: 

sh version
sh boot
dir

I sure will as soon as I get in the office in the morning!

TW80CJ5
Participant

Had an office closure with Covid. I hope to be able to obtain additional information for you all in the morning!

TW80CJ5
Participant

It was my inability to follow the directions.

 

Here is what I did for a successful change from Bundle to Install

 

Verify the latest .bin IOS is on flash

 

sh run | inc boot

config t: no boot system flash: cat9k_iosxe_16.09.03.SPA.bin

config t: boot system flash packages.conf

Switch# install add file flash:cat9k_iosxe.16.12.04.SPA.bin activate commit

Enter Y

"Do you want to proceed" Enter Y

Approx 15 minute upgrade process


After upgrade


sh ver

Verify it says install and lists the latest software version you were trying to upgrade to


Removing old files

switch# install remove inactive

Enter Y when prompted

Leo Laohoo
VIP Community Legend

Did you need to apply the SMU?

Apply the SMU...???

Leo Laohoo
VIP Community Legend


@TW80CJ5 wrote:

Apply the SMU...???


There is a reason why I always sound like a broken record and recommend people to read the Release Notes.  

9300 files, for 16.12.4, can be found HERE.  See and evaluate if you need to apply the SMU.  

WARNING:  

Do not believe in the "Hitless" heading -- Some SMU will reboot the stack.  

Hahaha!!! Seems like I have read your other posts where you mention that. And I know better to not check.

We are running 9300-48U-A switches so that doesnt apply to us...???

 

We havent been experiencing any of the problems listed.

 

Thanks Leo!!!