cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
667
Views
0
Helpful
7
Replies

Cisco c2960x UPLINK, ping from a not native Vlans.

boldobaldo
Beginner
Beginner

Hi all, and thanks for the support. 
I've got a little trouble and i can't resolve it. 
I've got a new Cisco C2960x switch.
I've properly configured all the things that i needed and put it in my lan. 

On the uplink switchport, the native vlan is the vlan 1. 
I can ping and have access in to the switch from all the LAN's switches, through vlan 1. 
But the switch is not available from the other vlans, and that is mandatory for me. 

The config of the switchport: 

 

xxx# show interfaces gigabitEthernet 1/0/25 switchport
Name: Gi1/0/25
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

I miss something? where is the missing point? 


Thank you all, 

Baldo. 

7 Replies 7

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

     - What does the running-config of this port look like ?

 M.

interface GigabitEthernet1/0/25
!

kapydan88
Enthusiast
Enthusiast

It look, like you have problem with L3. Where routing is implmemented?

 

Do "sh run" and copy output.

xxx#sh run
Building configuration...

Current configuration : 4805 bytes
!
! Last configuration change at 10:27:14 UTC Wed Apr 14 2021
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mensa
!
boot-start-marker
boot-end-marker
!
enable secret 9 $9$vmmToA5d2ay5ne$MjzwBhg6Anf4fbKj7N.TUCmq0t549dt6H7KiWpIGUCc
enable password 4pr0c-2020
!
no aaa new-model
switch 1 provision ws-c2960x-24ps-l
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3024782208
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3024782208
revocation-check none
rsakeypair TP-self-signed-3024782208
!
!
crypto pki certificate chain TP-self-signed-3024782208
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33303234 37383232 3038301E 170D3231 30333131 31303330
31305A17 0D333030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 30323437
38323230 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100DCEF 5FD12C43 3BAAC974 63BB4C5E 86E2A543 CF7996FF 4F23653F DA1AAD70
FBCA8A6A 00B409B0 7AB37F2E 8E12E3AE CA5E473E 35D5A002 53972865 D71B6B4B
76E5B0D5 AF678B8A 2B761823 2B53F846 B67BC0BB 94D34008 F2EDA15B 437F2C27
00A3264D C69D0246 20A7572D B95E6A77 0C7BC997 0E1A75FF AFDA6207 35F80CA5
7F4D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 142FE3DD DD713AF1 41ABE828 C42CEB55 956FEEEE 5B301D06
03551D0E 04160414 2FE3DDDD 713AF141 ABE828C4 2CEB5595 6FEEEE5B 300D0609
2A864886 F70D0101 05050003 8181001A 27616F56 3807FAFB 293CDAC9 A0E3C49C
35755379 01AB5796 4126A586 52033493 5E3C0874 CF66236A 716898F9 668318C5
5E112968 1E79041E B4FC4BE7 B87F3566 B2796506 0BC17F00 CE237EBD C9F3C224
C25E9CC4 CCD3792F 57187709 2FBDD476 FBCF737F 9199814C FB49E154 D5A20929
2D295D40 84DED5E0 B3EFC06F 77A2D6
quit
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
no spanning-tree vlan 1,200,251
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
no ip route-cache
!
interface GigabitEthernet1/0/1
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/5
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/11
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/12
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet1/0/13
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/14
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/16
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/17
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/18
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/19
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/21
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/22
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/23
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/24
switchport access vlan 251
switchport mode access
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
switchport trunk allowed vlan 1,200,251
switchport mode trunk
!
interface Vlan1
ip address 10.xx9.2xx.7x 255.xx5.xxx.128
!
interface Vlan200
no ip address
!
ip default-gateway 1x.1xx.2x5.1
!
ip http server
ip http secure-server
!
!
!
!

!
end

Gi 1/0/25 do not have any config at all ?  you looking config to be Trunk ?

 

interface range GigabitEthernet1/0/25
switchport mode trunk

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

So if i change the uplink cable from the Gi 1/0/25 to Gi 1/0/28 all gonna be fine?

 

I've got an Alcatel switch on the other side of the uplink, with a port that have Vlan 1 as default Vlan ( untagged ) and the 251 and 200 tagged 802.1q. ( tagged ).

 

So, its the port gi1/0/28 correctly configured to work?

below configured one should be able to working, as Native vlan by default 1 here, or no harm mentioning default native vlan in the config also. test and advise.

 

interface GigabitEthernet1/0/28
switchport trunk allowed vlan 1,200,251
switchport mode trunk

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers