cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
699
Views
0
Helpful
15
Replies
mel-ghazali
Beginner

Cisco LMS 4.2.5 "Services never started"

Dears;

I have LMS 4.2.5, I found it's not operating, I checked processes, and I found services shows "NOT started yet " then after failed to  "Never Started".

I checked Windows event viewer I found the following errors "Event ID 1 from source SQLANY 10.0 " regarding databases.

I followed this procedures "Recovering from Crash" part, most of services got up but the with some services down.

and from the event viewet I have the following errors

  1. The description for Event ID 1 from source SQLANY 10.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    ANIDbEngine

    *** ERROR *** Assertion failed: 201501 (10.0.1.4310)

    Page 0x0:0xa612 for requested record not a table page

  2. The description for Event ID 1 from source SQLANY 10.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    CmfDbEngine

    *** ERROR *** Assertion failed: 201503 (10.0.1.4310)

    Record 0x1 not present on page 0x0:0x7d3f

  3.  

    The description for Event ID 1 from source SQLANY 10.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    ANIDbEngine

    *** ERROR *** Assertion failed: 201503 (10.0.1.4310)

    Record 0x14 not present on page 0x0:0x8414

also I found that all devices and configurations is empty,,, any help regarding this issue. please

1 ACCEPTED SOLUTION

Accepted Solutions

Hi

for the syslogs::

 

go to the below location::

Admin > Collection Settings > Syslog > Syslog Collector Status.

check and make sure you are seeing the "forwarded" counter increasing

 

if counters are not increasing , try to un-sbuscribe and subscribe the syslog collector from the same window

**you can also try to restart the

syslogCollector and syslogAnalyzer process

 

2. for the Ip phone , is the call manage added successfully

also ,make sure the ip phones are registered fine

 

Thanks-

Afroz

***Ratings Encourages Contributors ****

 

 

 

 

 

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

View solution in original post

15 REPLIES 15
AFROJ AHMAD
Cisco Employee

-Share the output of "pdshow"

-any changes on the server like hostname change ?

-md.properties (NMSROOT/CSCOpx/lib/classpath)

 

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Thanks for reply.

no change on hostname happened, the only interesting thing happened that the C:  drive free space was 3 GB only,

find attached the output for pdshow and md.properties

have you cleared some space on the server ?

have some more free space on the server and restart the LMS service or just reboot the server once

 

Thanks-

Afroz

****Ratings Encourages Contributors ***

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

yes I already did that as first action with no change. but it seems that file corruption occurred.

hi ,

 

try to regenerate the SSL::

 

To generate a new certificate in LMS

1. Stop the daemon Manager

a. Windows: net stop crmdmgtd

b. Solaris: /etc/init.d/dmgtd stop

1. Remove the following certificate files from (NMSROOT/MDC/Apache/conf/ssl)

a. server.crt

b. server.key

c. server.pk8

d. server.csr


2. Disable SSL:

NMSROOT\CSCOpx\bin>perl "NMSROOT\CSCOpx\MDC\Apache\ConfigSSL.pl" -disable

for e.g

D:\Program Files\CSCOpx\bin>perl "D:\Program Files\CSCOpx\MDC\Apache\ConfigSSL.pl" -disable

3. Enable SSL to generate certificate:

NMSROOT\CSCOpx\bin>perl "NMSROOT\CSCOpx\MDC\Apache\ConfigSSL.pl" -enable

 

for e.g

D:\Program Files\CSCOpx\bin>perl "D:\Program Files\CSCOpx\MDC\Apache\ConfigSSL.pl" -enable

 

4. Start Daemon Manager

 

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

i did but unfortunately the same.

-share "pdshow -brief output"

-dcrserver.log

-last 200 line of "syslog.log"

ctm_config.txt from NMSRROT/CSCOpx/MDC/tomcat/shared/lib

-check the size of "redgemon.xml and regdaemon.xml.bck " , are they same in size like 80 kb

 

Is the server running under domain ?

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

first of all, thanks for interest.

find attached the outputs,

regarding regdaemon.xml and regdaemon.xml.bck are the same size 82.7 KB

regarding syslog.log what is the path for this file ???

hi,

 

Is this a windows server or linux ?

 

if windows ,share the screeshot of " services.msc " windows showing LMS services

 

Thanks

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

find attached.

follow the below steps::

1.stop the daemon manager

2.

remove or backup the cmf.log ( NMSROOT/CSCOpx/database/cmf)

and

remove or backup the ani.log ( NMSROOT/CSCOpx/database/ani)

3.Ran this command, Browse to 

NMSROOT\CSCOpx\databases\cmf  >dbsrv10.exe -f cmf.db 

 

and

 

NMSROOT\CSCOpx\databases\ani >dbsrv10.exe -f ani.db 

 

4. start the Daemon Manager.

 

Thanks -

Afroz

***Ratings Encourages Contributors ****

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

I did , but no change.

Hello AFROJ;

at the end i did a new fresh installation 4.2.5 on windows 2012.

but i have two questions for you.

1- the server not showing syslogs on monitor> Event Monitor > Syslog.

while the syslog.log file have the logs from network devices.

 

2- regarding user tracking, the lms cannot get any ip phones from cisco call manager [version 10.5]

can you please help me in this.

Hi

for the syslogs::

 

go to the below location::

Admin > Collection Settings > Syslog > Syslog Collector Status.

check and make sure you are seeing the "forwarded" counter increasing

 

if counters are not increasing , try to un-sbuscribe and subscribe the syslog collector from the same window

**you can also try to restart the

syslogCollector and syslogAnalyzer process

 

2. for the Ip phone , is the call manage added successfully

also ,make sure the ip phones are registered fine

 

Thanks-

Afroz

***Ratings Encourages Contributors ****

 

 

 

 

 

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

View solution in original post

Content for Community-Ad