cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
363
Views
0
Helpful
0
Replies
Highlighted

Cisco prime 3.0 cluster not working after applying patch Prime Infrastructure 3.0 Device Pack 7

Hello  Community !

 

We are facing this issue and we would be glad to hear some tips or advice on fixing

 

Currently, we have 2 Primes 3.0 deployed in HA mode, but when we tried to apply the Prime Infrastructure 3.0 Device Pack 7 the system entered in some stuck state and now its not working on primary and secondary.

 

The prime version was 3.0 3.0.0.0.78 and we proceded with the following steps to install the update:

 

1.- Deactivated HA mode

2.- Applied update in Secondary host, everything went ok.

3.- Applied update on Primary host, but during the start of services we faced DB problems so ncs didnt start

4.- Tried to apply rollback but the repository was empty

 

After this, primary and secondary node are out and Prime dashboard is offline, we can access to both health monitor and we can see following:

 

 

On health status, the primary host shows this repeating every minute:

 

Sep 07, 2018 12:42:43 PM HA not Configured Prime Infrastructure service failed and cannot be restarted
Sep 07, 2018 12:42:43 PM HA not Configured

failed to start Prime Infrastructure services

 

 

On secondary host the logs show this:

 

Sep 05, 2018 04:52:33 PM HA not Configured Secondary Prime Infrastructure Server started successfully as standby
Sep 05, 2018 04:45:16 PM Health Monitor Available Health Monitor Started
Sep 05, 2018 04:42:21 PM HA not Configured Administrative Shutdown
Sep 05, 2018 12:35:21 PM Administrator Secondary Authentication Key was changed by Admin
Sep 05, 2018 10:38:11 AM HA not Configured Secondary Prime Infrastructure Server started successfully as standby
Sep 05, 2018 10:24:53 AM Health Monitor Available Health Monitor Started
Sep 05, 2018 10:17:02 AM HA not Configured Administrative Shutdown
Sep 05, 2018 09:57:36 AM HA not Configured Decomission successfully completed
Sep 05, 2018 09:45:12 AM Secondary Alone Decommissioned Prime Infrastructure Server '10.190.3.50 [10.190.3.50]'

 

When trying to start NCS on primary the message says the following:

 

Prime-TIC/admin#ncs start

Sttarting Prime Infrastructure...

This may take a while (10 minutes or more) ...
Unable to query db role. Error: ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux-x86_64 Error: 2: No such file or directory

 

 

Prime-TIC/admin# ncs status
Health Monitor is running, with an error. ( [Role] Primary [State] HA not Configured )
failed to start Prime Infrastructure on startup Health Monitor
Database server is running
Ftp Server is running
Tftp Server is running
Matlab Server is running
Matlab Server Instance 1 is running
Matlab Server Instance 2 is running
Matlab Server Instance 3 is running
NMS Server is stopped.
CNS Gateway with port 11011 is down
CNS Gateway SSL with port 11012 is down
CNS Gateway with port 11013 is down
CNS Gateway SSL with port 11014 is down
[Plug and Play Gateway Broker with port 61617 is down
Plug and Play Gateway config, image and resource are down on https
Plug and Play Gateway is stopped.
SAM Daemon is running ...
DA Daemon is running ...
Compliance engine is running

 

Also i noticed the size of oracle db was lot different on both nodes:

 

Primary:
ade # du -sh /opt/oracle/
23G

Secondary:
ade # du -sh /opt/oracle/
53G

 

 

Currently we dont have any access to prime dashboard and in the health monitor the button to failover is not available.

 

Any help would be appreciated. !

Everyone's tags (5)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards


This widget could not be displayed.