cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2308
Views
0
Helpful
7
Replies

Cisco Prime 3.9 - import data from 3.5 install

Brett Verney
Beginner
Beginner

Hi all,

 

I noticed that you can't upgrade a PI 3.5 to 3.9, even doing a multi-step upgrade if the system ever had 3.4x or prior installed thanks to a RHEL vulnerability.

 

I am happy to build a new 3.9 VM - but my questions is, will I be able to import the 3.5 maps and configuration backups directly in to 3.9?

 

-Brett

1 Accepted Solution

Accepted Solutions

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

You need to have 3.7 minimum to data restore on 3.9 (but you need to go as below )

 

3.7 take backup config

Fresh install of 3.8 and restore (no less tahn 3.7 backup config will be accepted here)

after restore, you can do inline upgrade to 3.9

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

7 Replies 7

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

You need to have 3.7 minimum to data restore on 3.9 (but you need to go as below )

 

3.7 take backup config

Fresh install of 3.8 and restore (no less tahn 3.7 backup config will be accepted here)

after restore, you can do inline upgrade to 3.9

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Ulrik Rosen
Beginner
Beginner

Hi

I have tried to go to 3.9 with a 3.7 backup and gets the unsupported error when trying

Why do you need to go through 3.8 before going to 3.9, the manual/release notes states that you can go to 3.9 and restore a backup from 3.7

 

I

 

 - FYI : https://www.cisco.com/c/en/us/td/docs/net_mgmt/prime/infrastructure/3-9/release/notes/bk_Cisco_Prime_Infrastructure_3_9_0_Release_Notes.html

    >...

           If your existing Prime Infrastructure is 3.7.x or 3.8.x, and your upgrade path contains 3.4.x or earlier versions, then you cannot in-line upgrade that server to Prime Infrastructure 3.9 due to security vulnerabilities in the underlying Red Hat 6 installation. You will need to take a backup of the Prime Infrastructure 3.7.x or 3.8.x server, deploy a fresh Prime Infrastructure 3.9 server, and restore that backup into the Prime Infrastructure 3.9 server.

 

 M.

Ulrik Rosen
Beginner
Beginner

I am aware of the fresh 3.9 install reference and that is what i tried with the "not supported" error, the backup is from a 3.7 system

Can the step with a fresh install of 3.8 and a inline upgrade to 3.9 solve this problem?

 

 

 - Although there is room for doubt in the mentioned statement , I would still not advice it and go for the fresh install option (3.9) and restore the 3.8-environmant from backup.

 M.

Ulrik Rosen
Beginner
Beginner

Hi again.

I have succeded with the restore of the 3.7 db to a fresh install to a 3.8 system. 

One important thing is that the backup taken MUST explicit be an application backup of the 3.7 system

This was my original mistake when trying to restore an appliance backup instead of a application....

 

So dont forget to check your backup from the older system so that's a applicaion backup

 

This small but important note should be added to the relasenotes and also to the install/upgrade guides

 

Hope this can be of some help in the upgrade process of the CPI

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers