Showing results for 
Search instead for 
Did you mean: 

Cisco Prime Infrastructure 3.3 - Device Bulk Import

Paul Hanton

I'm currently trying to import a large number of devices into Prime rather than running a discovery and I'm running into a few issues.


I've downloaded the sample csv file and tried to edit the file to include just one device as a trial.

I've tried using both notepad+ and Excel and neither files work.


Now here's the catch when I try to import the normal file I'm told

"Import failed: Ensure the imported csv file is in the correct format"
so I remove the title headers at the very top and the import is accepted in as a job, but I go to the job and its failed due to missing mandatory header errors.
"FAILED_Add Bulk Import Job Failed, Incorrect Input file. Missing mandatory header fields [ip_address].-INVENTORY_SERVICE_117 "
Has anyone been able to a Bulk import on PI 3.3? how did you achieve it?
9 Replies 9

Bill Longman
Cisco Employee
Cisco Employee

Yes, you need the headers in there but you don't need the example user-defined-field. You can remove that column if you don't have any UDFs.


That was really the only sticking point I ever had, Paul.

Hi Bill,


I tried this and it didn't work, I even tried editing the file with notepad + but it will only accept the file if I remove the headers. 


Hi Paul,

You may try to select  the add device manually. Try to add 1 device first and then once you have successfully added with no errors. You may try to export it in a form of .csv file which you can use as a valid template. Cisco Prime User Guide also has the informations which headers/columns are needed for you to successfully add a device.




Best Regards,


Just thought I would follow this up by saying i had to make sure that the relevant fields were correctly filled out


For V2 

ip, snmp version, community string, write community string, protocol, cli username, cli password


For V3

ip, snmp version, snmp retries, snmp timeout, protocol, cli username, cli password



You just have to ensure your snmp credentials, cli credentials and IP matches your devices. SNMP retries/timeout I leave it as default.


Besst Regards,


try to import the template as it is first

this is not the devices you need but you can check if the template provided is ok





0. I reccomend you to fill some devices manually and then make an export existing devices to csv file.

1. You need to create a excel file.

2. Import your csv file as a text with comma separating to your excel file. This would be more comfortable to add and edit new devices.

3. When your device list is ready, save it as .txt file

4. Open your .txt file, and with ctrl+H change all tabs to commas. Save file as .csv and upload to your PRIME.

5. Be happy




I have had the same problem. Then I have tried to export a defined device, but couldn't open the tar-file.

Now, I have successfully Bulk-imported a device list.

The point was, that in the example CSV, there is missing the column "network_mask". If missed, the error was "Incorrect Input ... [ip_address]".

So I have the following 2 first lines in the CSV, instead of all Passwords, etc, I have a credential profile with the name "Switch" :



The excel fields must be formatted as "text"image.png

After I´d edited that, my bulk has imported fine.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: