Showing results for 
Search instead for 
Did you mean: 

Cisco Prime infrastructure upgrade 2.0 failed

Hello , I am trying to upgrade from Cisco Prime (virtual machine Vmware) version: Patch : Cisco Prime Network Control System Version: Update - 1_12_for_version_1_3_0

to 2.0 using the following command:

application upgrade PI-Upgrade- defaultRepo

But i get the following message

Initiating Application Upgrade...

  Stage 1 of 7: Transferring file ...

  -- complete.

  Stage 2 of 7: Unpacking file ...

  -- complete.

  Stage 3 of 7: Executing pre-install ...

[ERROR] System does not meet minimum resource requirements:

- Disk space available [122224 MB] is less than the minimum required value of 200 GB for the /opt partition

but the total disk space is 350GB

fdisk -l /dev/sda

Disk /dev/sda: 375.8 GB, 375809638400 bytes

255 heads, 63 sectors/track, 45689 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System

/dev/sda1   *           1          64      512000   83  Linux

Partition 1 does not end on cylinder boundary.

/dev/sda2              64          77      102400   83  Linux

Partition 2 does not end on cylinder boundary.

/dev/sda3              77       25497   204184576   8e  Linux LVM

how can I do to increase it, or have any ideas ?

Sandeep Choudhary
VIP Mentor

Hi Ferrano,

Here is the link for you :

Hope you are looking for this



Thanks , but i had already read this post but i knew that with upgrade 1.3 the problem was solved , have you tried this method ?

Sent from Cisco Technical Support iPhone App

I have tried the same process and also tried to increase HD space (HD space increased) - no change with upgrade.

anyone tried anything else please.

PI basically runs on a redhat linux behind the scene. In prior release (small model) /opt file system is only 124GB. PI 2.0 (express) requires 200GB. Increasing the storage allocation to the VM does not do anything to the linux file systems such as /opt. It is a pretty complex process to resize the /opt. You need to increase physical volume, resize logical volumes, and then finally adjust file system. There is lot of technicality behind it, and chances are that most people will not succeed. You should know what you are doing at the Linux file system.  Time, effort and risk is not worth. Yes, Cisco should have taken care of this with the upgrade process.

Finally, I gave up on the in-place upgrade, and went for a migration which is lot easier and faster.

1)  Install necessary patches (1_12_for_version_1_3_0) and then take new application (NCS) backup

2)  Install new PI 2.0 VM, i.e., deploy OVF template, power ON, run setup (basic config)

3)  Restore (NCS) application backup.

That’s it, and you are done. You will have a clean PI 2.0

You can add extra space by shutting down the box via 'halt', adding a new virtual disk in VMWare, and starting up. Upon booting it will use the extra disk (VMDK) to grow the space /opt - adding RAM (from 8GB to 12GB is easy enough, as expected no guest interaction required).

I am on Prime 1.4 and have been told by TAC they will be releasing a fix soon, but at present it is not supported to upgrade 1.4 to 2.0 nor can a backup from 1.4 be restored to a fresh 2.0

FYI- I had tried that, i.e., increased memory to 12GB and disk space to 300GB for the VM, and rebooted VM. Upgrade failed again with same exact disk space requirements. Enabled root access and found out that underlying Linux file systems sizes were unchanged. Tried manually resizing physical volume (successful) and logical volume (failed). Long story short, after wasting half a day I decided to migrate our PI 1.3 installation instead of in-place upgrade.

I have solved

I'm following this guide
and adding additional commands that are missing.



Hi Guys

I want to know, if the license installed in Prime 1.3,  it is possible will transfer to a new clean install Prime 2.0?

I have installed the License:










Yes. I see 2 ways to do it.

Option 1.

- Take a application backup of 1.3.

- Do a fresh install of 2.0 and do basic setup, i.e., run setup when you bootup for the first time.

- Restore the 1.3 backup onto new 2.0 install. That's it. It will restored all config including the licenses. It worked for me without any problem.

Option 2 (if you don't need anything from 1.3 except license).

- Do a fresh install

- Rehost license, i.e., go to Cisco license portal and trasnfer the licenses from old host to new host to get new license keys for new host. I have tried this for other systems such as WCS, routers, etc., but not yet tried on PI, but I am sure it will work.


I had the same issue and found this in the 2.0 release notes:

"If you are upgrading from Prime  Infrastructure 1.x small virtual machine, you should create a new  virtual machine with the Express OVA, back up your existing small  virtual machine, and then restore it on the new virtual machine. You can  delete the old small virtual machine after the new virtual machine is  fully operational. Inline upgrade of the small virtual machine is not  supported."

I originally installed the small version which the express supposedly replaced but the number of supported devices dropped big time which make no sense. Well, having to build another server instead of being able to upgrade makes no sense either. Don't even get me started on the whole WCS to Prime migration...

In the end I'll need to go to the new standard install which is way overkill for us. Small was just perfect.

1.2 Scalability

2.0 Scalability

I just upgraded from Prime 1.3 to 2.0. I installed the Express version of Prime 2.0, backed up PI 1.3 and restored on Prime 2.0 however the licences didn't come accross? Prime 2.0 still has the evaluation licence installed.

Did I miss a step here? Will I need to go to Cisco to get new licences for Prime 2.0?


If you moved to a different host, the VUDI (Virtual Universal Device Identifier) would have changed. Prime Infrastructure license files are keyed to a unique VUDI (or UDI in the case of a physical appliance) and would have to be re-issued to rehost on a different VM.

You'll need to contact the TAC to have your license re-issued.

Thanks Marvin

Sent from Cisco Technical Support iPhone App