Showing results for 
Search instead for 
Did you mean: 

CNA 6.3.1 seems very buggy

I see several others posting various issues with CNA 6.3.1, and I seem to have them all, plus a couple I don't see mentioned. I have tried it with Windows 10, using no compatibility, Windows 7 compatibility, and Windows XP SP3 compatibility, with results that get worse instead of better. I also loaded it on Server 2012, but same results.


My two biggest issues are that the behavior for a given session is unpredictable, and the topology display has become useless.


By unpredictable, I mean I run the same program from the same machine and get mixed results. Sometimes, my main switch (4503) will not connect, rejecting authentitaction, though I can connect to it directly with a browser or TELNET or console, all with the same password. Sometimes, it connects to 4503, but identifies it as an unsupported device. Sometimes, everything is fine with the 4503, but other switches (I have a mix of 28xx and 29xx series) may or may not authenticate and/or show as unsupported, or sometimes even show that they could not connect at all, while other times, changing nothing, everything seems to show up and be manageable.


For the topology, it has become a tangled mess. I cannot turn off neighbors like our IP phones to reduce clutter, while other neighbors, like a pair of 3COM managed switches I have, don't even show up. The wiring only lands on the device icons if I use auto arrange, and even then it doesn't always work. Clicking auto arrange turns back on all the neighbors. Moving anything, or even just clicking in the display area, causes the whole wiring diagram to go crazy again, where no lines even terminate at a node, and many are just rays that go off the screen, even though all the devices are on the screen.


I had none of the problems above with 6.2 running on the same machines. I tried 6.3, and then 6.3.1, because the software was reminding me an upgrade was available, and I generally take updates to stay current. In my case, I was hoping to see resolution of the extremely slow performance from 6.2 and improvement in printing the topology. From 6.2, the printouts are not usable unless printed at 100%, as the text has been converted to bitmap fonts and they do not scale. For me, the map that I should be able to fit on a single sheet of paper to show the seven devices in the community I'm interested in documenting is worthless. I have to blow it up to 6 pieces of paper before the text becomes readable.


In this case, I have no choice but to uninstall and go back to 6.2 and hope Cisco can do a better job on the next release.

1 Accepted Solution

Accepted Solutions

I may have found a solution!


I took the C:\Program Files (x86)\Java\jre1.8.0_144 folder and copied it to C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages and renamed it "runtime-1.80" so it matched the format of the existing folders - and so it is easier to edit in the next step. You will find there is a runtime-1.62 from Cisco in there.


Next, I edited the JAVAPATH in C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\startup\ to the following:




Upon launching CNA, my Topology View no longer freaks out. 

View solution in original post

8 Replies 8

Just a quick update for anyone who might care. The problems I experienced above are very repeatable, and resolved by moving back to version 6.2 with one exception. Even with 6.2, I have to enter the password for my 4503 four times during program initialization and initial discovery for a community I have already defined. When the community finally opens, it then shows the 4503 as an unsupported device. I wait a minute, then refresh, and everything is cool after that. Why does CNA remember the passwords for all the other devices, but not the 4503? Why do I have to enter it four times on every open?

For what it's worth, I think most of the issues are with Java. When I tried to uninstall v6.3.1, I received "A suitable JVM could not be found...", though I have the latest version of Java installed (SE8). IN order to get the uninstall to work, I had to point the uninstaller to a SE6 version embedded in the CNA program files structure. So, even though version 6.3.1 was just recently released, it still apparently relies on a Java version from 10 years ago, and doesn't play well with current versions. For grins, I'm going to install on an XP SP3 machine with Java SE6 and see if it works better.