Showing results for 
Search instead for 
Did you mean: 


DCNM and running LAN client

I have been trying to install DCNM to evaluate and monitor our Nexus kit but so far its not going well.     It seems to be incredibly flaky - the first couple of installs I did successfully completed but the DCNM-LAN server service failed to start at all and a couple of hours of troubleshooting failed to find out why.      The server was then completely rebuilt and I've now installed a newer version of DCNM    


Amazingly the service actually started on this version but then I tried to download and run the LAN client and thats when my problems began.. When I access the link to download the client (why couldn't Cisco just install a normal client like the SAN client which works reliably ????).  I  Installed the version of java asked for (which is fairly old) and then tried a newer one and the 'Launch DNCM-LAN Client' button either completely fails to do anything or brings up an error 'unable to download dcnm.jnlp' message. This is depending on what browser I use and whether I try to run from the server or from my pc.      After looking at the sourcecode for the page it looks like it should be checking the java version and if its newer than 1.6.029 (old) it should run DCNMLatest.jnlp and if its older than this it should run DCNM.jnlp.      Occaisonally I would get an error saying javaversionutil was being blocked but I don't know what this does.  As our java version is newer it shouldn't be even trying to run the older version on the occaisons it tries and fails to download it.

I then tried running DCNM.jnlp and DCNMLatest.jnlp manually and finally managed to get the client logon window to appear, however when I type in the username and password in and verify the port , all I get is 'Connection to server failed'.   :-(    

Netstat -an shows port 1099 is listening so now I'm a bit stumped.

Anyone any ideas about this, I'm doubting whether its now worth the hassle for such dodgy piece of software.   Admittedly our servers are fairly tied down security wise but the SAN client has worked reliably on every version!

Any ideas?



CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards