Showing results for 
Search instead for 
Did you mean: 

Device Credentials error with LMS 4.0


I'm having some issues backing up configuration (startup and running) files for some managed devices with LMS 4.0.   

Under the collector status for one of the devices is shows:

Discovery Success, Data collection  Success, User Tracking   Success, Inventory  Success, Fault discovery Success, but Config Collection  Failure

Under Reachability Status I see all of the protocols Success except SNMPv1, SNMPv2 and HTTP have failed.  If I run a Device Credentials verification, I get the following: Read Community = OK, Read Write Community = No value to test, Telnet = Incorrect, Enable by Telnet = Did not Try, SSH = OK (Primary Successful) and Enable by SSH = Enable username credential missing.  However under the same device all of the credentials are in there, like the main username with the enable password, plus a secondary account as well and still nothing.  I tried to search for that error but I have not been able to figured out what steps to take to fix the issue.

Any help would be greatly appreciate it. 


Duong Nguyen

You have to update your SNMP Timeouts.

Admin > Collection Settings > Config> Edit the Inventory/Config Timeout and Retry Settings

retries: 3

Timeout interval 45

telnet timeout 1000

tftp 5

read delay 300

transport timeout 45000

login timeout 2000

tune sleep 50

delay after connect 300

Hi duong.nguyen7 it didn't work, I get the same error.  Plus, I was not able to find the second set of options under Inventory/Config Timeout and Retry Settings.  only the first one, which I changed and nothing.  any other ideas?  Thanks! 

Device Attributes

Field Name


SNMP Retry(0-6 Count)*
SNMP Timeout(Min 0 Secs)*
Telnet Timeout(Min 0 Secs)*
NAT'ed IP Address
TFTP Timeout(Min 0 Secs) *
* - Required

Inventory > Job Browsers > Device Credentials Verification

Run a DCR report on a particular device that fails and post it

This is another node that's having issues, but if I fis this one, i got a feeling that it will fix the rest as well.  thanks for your help. 

Can you post the logs of the config backup/archive that fails?  I remember fixing this problem a while back...just trying to remember what exactly I did.

Perform another backup and send me the job folder so I can look at the logs.

try to open HTTPS service and check

aman hussain, does HTTPS needs to be enable? I just noticed the node am troubleshooting with doesn't have it enable. 


I found the problem, all I had to do is edit the TacacsPrompts.ini file and boom, issue fixed.  Thanks guys for taking the time to reply...