Showing results for 
Search instead for 
Did you mean: 

DFM doesn't show name of a device

Hello! I add device in Device and Credentials with IP, hostname, domain name and credentials for snmp. Then add it manually to DFM. But DFM shows this device only by IP address. As I know it must use DNS name if it possible to resolve device in DNS server. Records in DNS about device was made. How can I configure DFM to show device by DNS name or other name?

Joe Clarke
Hall of Fame Cisco Employee

DFM does not respect the DCR display name, so the only way to make a device show up in DFM by a name is to make sure reverse DNS is working at the time the device is managed by DFM. That is, the IP address must resolve to the desired name. If DNS was setup after DFM managed the device, remove the device from DFM, and re-add it.

DNS works right, and operating system where DFM is placed can resolve any ip. I say more some of devices shown in DFM right with their domain names. But some steel shoun only by ip.

Joe Clarke
Hall of Fame Cisco Employee

Check those devices that only show by IP using the command. For example, if device is only showing up by IP when you want it to show up as, then do:

NMSROOT/bin/perl NMSROOT/bin/

(NMSROOT is the path into which CiscoWorks is installed.)

What you should see from the above command is:

Original name:

Hostnames/IP Addresses:

If you don't see that, you need to correct DNS or the local hosts file until you do. Then do:

NMSROOT/bin/perl NMSROOT/bin/

You should see:

Original name:

Hostnames/IP Addresses:

If you do, then delete and re-add the device to DFM. If not, then once again fix DNS or the local hosts file until you do.

I've try to launch script and all my ip addresses was resolved well. Then I've try to delete and re-add device to DFM, but it doesn't help. I'm sure, DNS configured right.

Joe Clarke
Hall of Fame Cisco Employee

Try editing NMSROOT/objects/conf/discovery/discovery.conf, and change NameFormat from TM_USESEEDNAME to TM_USEAUTONAME. Restart dmgtd, then remove and re-add the problem device, and see if that helps.

Thank you it really help.

I have a simillar problem with DFM as well as other CW LMS Apps not showing Device Names. Unfortunatelly I did not manage to follow your advice. 1)I found the file you speak about but in a different location: NMSROOT/objects/smarts/conf/discovery/discovery.conf 2) I cannot locate dmgmtd at all. Can you help? Mirek

/etc/init.d/dmgtd stop

/etc/init.d/dmgtd start

I am using Win version of CiscoWorks. I managed to locate dmgtd in the end, however, in a different location. Anyway it seems that the Win version of dmgtd does not support start and stop commands. I restarted the machine, removed/added the device/s in question from CS and it started to work in DFM and even in CM.

Later I set the NameFormat from TM_USEAUTONAME back to TM_USESEEDNAME and it wokrs too. It appears that removing/adding the devices from CS is enough. I summarized the steps which worked for me below:

CiscoWorks - How to display device names in CW apps


1) CM>Administration>Device Discovery>Discovery Settings> enable "Use Reverse DNS Lookup"

2) Configure the ip address resolution in DNS (reverse domain) or in the hosts file (C:\WINNT\system32\drivers\etc\hosts)

3) Devices need to be removed from administration and again discovered:

CS>Device and Credentials>Device Management> delete devices in question from CS@LMS

CM>Administration>Start Device Discovery, wait and when completed >Start Campus Data Collection, wait until completed

4) that's all folks

Hopefully this come usefull to someone.


Content for Community-Ad